2

I earlier installed glib-2.42 which was needed as a dependency for a program. But some softwares(sublime text) stopped working and were showing error related to glib. So i downgraded the version to 2.28. Now sublime worked fine with 2.28 but then occurred a conflict between 2.42 and 2.28 version which showed the error:

*** 'pkg-config --modversion glib-2.0' returned 2.28.8, but GLIB (2.42.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: Cannot find GLIB: Is pkg-config in your path?

THIS i am trying to solve for days and couldn't really find a solution(have tried everything suggested on the forum).

SO NOW, i without realizing, deleted all glib-2.0 files from/usr/include and /usr/share thinking to reinstall glib2.28 back from source thinking that i would get those files back.

But it didnt happen and now i cannot run anything(pidgin, sublime, libreoffice..) and i get the error:

GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

Can i get all the files back? Its urgent. I have already done apt-get install libgtk2.0-dev libglib2.0-dev

EDIT : and when i install gsettings-desktop-schemas, it shows gsettings-desktop-schemas is already the newest version.

6
  • How did you install glib-2.42 and to where (/usr or /usr/local)? How did you "downgrade the version to 2.28"? Have you tried an apt-get install --reinstall of the relevant packages? Mar 14, 2015 at 15:30
  • It was installed from source. I just did the make uninstall of 2.42 and then installed 2.28 over it. then modified the paths.
    – awhitesong
    Mar 14, 2015 at 15:35
  • Thanks for the concern. I found the solution. Was going to answer it myself after a while. Recent glib versions doesn't have all the compilation schemas in /usr/share/glib-2.0/schemas. So i just copied them from somewhere else. Although i guess they are available in only some of the older glib versions.
    – awhitesong
    Mar 14, 2015 at 15:41
  • @awhitesong Can you post the complete answer? Thanks! Jul 13, 2015 at 17:35
  • @Mandx Actually my main aim was to downgrade glib-2.42 to 2.28 and get it working properly in the system. During the whole procedure i came to this glitch. So what case you need the solution for ? Just this specific problem or the whole downgrading process, which i believe although worked still shouldn't be followed as a recommended procedure since i manually deleted some files? As for this specific problem, i just searched online and added all the schemas required, in /usr/share/glib-2.0/schemas since they got removed when i deleted my glib folders unknowingly. Thanks.
    – awhitesong
    Jul 14, 2015 at 1:42

1 Answer 1

0

In Ubuntu Jammy, glib-2.0 is in libspice-client-glib-2.0-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.