I did a clean install of Ubuntu 14.04 LTS. I'm having a weird problem that I can't find any mention of online. Basically, all UI elements in apps look grey, Windows 98-style.

Here's GParted (Gparted)

And Geany (Geany IDE)

And the file upload dialog in Firefox (Firefox file upload)

Functionally everything is fine, but it just looks ugly. Unity,the desktop and the login screen look completely normal. Logging out and back in fixes the issue, but it comes back after rebooting.

  • Happened to me sometime. Do you have autologin? In my case it was some daemon too slow to start, so waiting a bit after boot to do the login solved the thing. I don't remember what was --- some dbus/session thing, I think. Can't find more details.
    – Rmano
    May 21, 2015 at 15:57

5 Answers 5


This right here is an easy fix. All you have to do is go to the software center and install Ubuntu tweak.

  1. Open that up and go to "Tweaks"
  2. Go to "Theme"
  3. In there, change the Gtk theme to whatever you like.

Ubuntu Tweak

That should fix it up no problem


There might be many reasons for this problem, but it can typically be fixed by re-configuring your themes. You can start by tweaking the theme in unity-control-center and making sure it is set to Ambience. If it is, try switching the theme to a different one and back. You can also try reinstalling the themes as suggested in this answer: https://askubuntu.com/a/141375/341801 for 12.04.


Have you tryed use software-center and install tweak tool, and you run tweak tool and set the window and icons to something else, and it should look better then grey, and you should install gnome system settings, and there you can also set settings, and it might work fine this way.


You can have a theme misconfiguration. Try this:

  1. Go to the gear cog that is on the top-right corner on the screen.
  2. Select System Settings from the menu.
  3. On the system settings, click on Appearance
  4. In the bottom-right of this window, you have a theme selector. If Ambiance is selected, select another theme. You may need to wait a few seconds until the new theme applies.
  5. Select Ambiance theme again.

I had this same problem (It didn't always happen) and found that it's somehow related to my graphics driver. The way to solve it was to, at startup time, stay at the login screen for about 45 seconds to a minute. Something "clicks" in X.org that allows it to go into the high graphics mode and load the nice looking theme.

I posted the related question over here: https://askubuntu.com/questions/628141/multiple-monitor-configuration-is-delayed-for-40-seconds-on-ubuntu-14-04-lts

  • 1
    I think this might be my issue. If I log out then log back in again, it works fine, I haven't tried leaving it at the login screen but I'll try that. Ubuntu's never played that nicely with my AMD APU, so I wouldn't be surprised.
    – Joe Malt
    May 27, 2015 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .