0

I installed Ubuntu 14.04 last month after a long layoff (April 2014) from programming PHP scripts accessing a MySql database. I have always installed and used XAMPP for years. When starting XAMPP with

sudo /opt/lampp/lampp start

XAMPP attempts to start its own Apache2, MySql and ProFTP. If another webserver, mysql or ftp is already running, XAMPP fails to start.

Now I am informed that another web server and FTP are already running; I have encountered this in the past. But previously I was able to

sudo service apache2 stop    
sudo service mysqld stop    
sudo service ftpd stop    
sudo /opt/lampp/lampp start

and XAMPP would start and run as expected. But now apache2 and ftp are unrecognized services, And I can't even find them in /etc/init.d or using initctl list or anywhere.

Has it been renamed ?

  • They haven't been renamed. Did you install the apache2 packages as well, alongside XAMPP? What does sudo netstat -tnlp say? – muru Mar 14 '15 at 0:07
  • Thanks for your response, but I found that rebooting the system from shutdown fixed the problem. I think it was caused by the wifi USB I am using (no ethernet available) being inserted after booting. If I boot with the USB inserted, the procedure I usually use works fine. – Reggie Mar 14 '15 at 13:04
0

I don't use the convenience LAMPP / XAMPP packages; I just installed apache2, mysql, etc, normally. That said, for me, sudo service apache2 restart works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.