6

I am using a system with Intel HD Graphics 2500 (Ivy bridge) and I have a little problem when playing Minecraft. Sometimes, my screen flashes blue, but only for a second every once in a while. Every 10 seconds or so, I see the flash. It only happens when I move or shortly after I move. If I stay absolutely still, it never happens. It happens with both OpenJDK 7 and Oracle Java 8. I have checked the X11 logs and have not found anything strange. I have experimented with every Minecraft setting but have yet to find anything that works. Also, I have noticed that the flickering does not happen if I make the window small. What is going on?

1
  • 1
    Full screening the window helps to ;)
    – user585288
    Aug 22 '16 at 16:56
2

Install Intel drivers for Ubuntu: https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-linux-1.0.7 it will solve your problem and you will see an fps improvement.

3
  • I will be honest with you: I didn't think that would actually work. I am more than familiar with the Intel Linux Graphics Installer, but I thought that the Utopic graphics stack would have been better. I guess I was wrong. Thank you!
    – John Scott
    Mar 14 '15 at 2:02
  • You are welcome, anything you need I will be here to help. Remember that sometimes the easy way is the correct way! :)
    – Brask
    Mar 14 '15 at 10:42
  • I have found out something interesting. The Intel Linux Graphics Installer is no longer supported on Ubuntu 14.04. However, this issue can still be fixed by installing the updated X.Org stack from Utopic by running the command sudo apt-get install xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic xserver-xorg-input-all-lts-utopic. Do NOT use the Intel Linux Graphics Installer on Ubuntu 14.04; it's obsolete! That's why I removed the installer along with Intel's drivers and switched to Utopic's graphics stack.
    – John Scott
    Mar 25 '15 at 22:23
5

Try this simple solution before reinstalling/changing drivers/changing java runtime/settings/etc.

Resize the Minecraft window to be just a little less than fullscreen. This solved the screen flashing problem for me, running Minecraft on Ubuntu.

2
  • Nice easy fix. Also switching from full-sized window to actual full-screen fixed the problem for me
    – pdizz
    May 1 '16 at 18:04
  • Worked for me. I have no idea why.
    – DavidW
    Jun 15 '16 at 19:21
1

I had the same issue running Minecraft while Compiz was running (it was fine before I started using Compiz). I lowered the maximum framerate in Minecraft from 60 FPS to 30 FPS and it seems to have gone away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.