30

How do I change the monitor's refresh rate in Oneiric?

There is no option to do it in the Displays dialog now. By default it's 60Hz, but I need 75Hz on my monitor.

In previous releases there used to be such an option in the Displays dialog.

Edit - Half baked solution

The best I could do so far was:

xrandr -s 1280x1024 -r 75

This is perfect, but my problem is that it isn't permanent. It defaults back to 60 Hz after logging out and back in.

Perhaps this should go into some script and added to startup? I just don't know how to do that.

2

4 Answers 4

21

You should be able to use xrandr. Calculate the needed modelines for your resolution and refresh rate:

cvt 1600 900 75

(Here my example resolution is 1600x900.) Now create a new mode with xrandr:

xrandr --newmode "1600x900_75.00" 104.00 1600 -hsync +vsync

Add the new mode to xrandr:

xrandr --verbose --addmode VGA-0 "1600x900_75.00"

and activate it

xrandr --output VGA-0 --mode "1600x900_75.00"

Note that your values will be different. In particular, your monitor might not be VGA. Run the xrandr command with no arguments to find out the name of your monitor and use that instead. Running xrandr -q will display a list of available outputs.

Here's some more information on xrandr.

4
  • This worked for me on Ubuntu 13.10. Thanks!
    – Zoltán
    Jun 1, 2014 at 13:10
  • 2
    This answer is not working as I expected pratik@pratik-SVE15116ENB:~$ xrandr --newmode "1368x768_75.00" 104.00 1600 -hsync +vsync xrandr: failed to parse '1368x768_75.00' as a mode specification Try 'xrandr --help' for more information.
    – Pratik
    Feb 13, 2015 at 18:38
  • 2
    how do you get the --newmode numbers from the cvt command? in other words, where does the 104.00 come from?
    – golimar
    Sep 25, 2021 at 17:28
  • Perfect! Thanks, once I did xrandr --addmode, the new refresh rate appeared in the GNOME settings. No need to activate it with xrandr. @golimar, the cvt command generated all the xrandr --newmode parameters. See the Arch Wiki on xrandr for details and example output.
    – SylvainC
    Oct 17 at 23:45
10

In 12.04 you can change the refresh rate by modifying the rate tag in ~/.config/monitors.xml after you configure your monitor(s). This works on reboot for me.

Example:

<monitors version="1">
    <configuration>
        <clone>no</clone>
        <output name="DVI-I-0"></output>
        <output name="DVI-I-1">
            <vendor>ACI</vendor>
            <product>0x24e1</product>
            <serial>0x01010101</serial>
            <width>1920</width>
            <height>1080</height>
            <rate>144</rate>
            <x>0</x>
            <y>0</y>
            <rotation>normal</rotation>
            <reflect_x>no</reflect_x>
            <reflect_y>no</reflect_y>
            <primary>yes</primary>
        </output>
        <output name="HDMI-0"></output>
        <output name="DP-0"></output>
        <output name="DVI-D-0">
            <vendor>DEL</vendor>
            <product>0xa017</product>
            <serial>0x31314553</serial>
        </output>
        <output name="DP-1"></output>
    </configuration>
</monitors>
2
  • After hours of searching this was the only solution that worked for me. Thanks a lot!
    – MrMaffen
    Apr 12, 2015 at 13:20
  • Hm, it says 144.00076293945312 in <rate>, but it's clearly not
    – Post Self
    Jan 4, 2018 at 18:15
7

So my solution is, which seems to work well on my system:

  1. I opened up Startup Applications

  2. I clicked Add

  3. I typed a name and the following in the command field:

    xrandr -s 1280x1024 -r 75

Using this xrandr -s 1280x1024 -r 75 is run at every sytem startup and sets the refresh rate as required. There could be a better option but right now this seems to be OK for me.

Hopefully the LTS will fix the showstopper bug of no easy, gui way to change the refresh rate.

3
  • 2
    actually, this does not run on system startup, but rather on (your) user login, which is quite different. The initial login screen will not be affected by this
    – MestreLion
    Jun 15, 2012 at 7:13
  • Also, after screensaver you'll need to run it again.
    – niry
    Apr 26, 2017 at 4:10
  • Rate 144.00 Hz not available for this size even though it is (it says right above when I run just xrandr)
    – Post Self
    Jan 4, 2018 at 18:09
6

The refresh rate for a monitor is automatically detected by Compiz.

If you wish to change it, install compiz-settings-manager you can do that with the command below.

sudo apt-get install compizconfig-settings-manager

Find in the dash "ccsm" and click the composite plugin.

Untick "detect refresh rate" and adjust the refresh rate to your manual setting.

enter image description here

6
  • 1
    I downloaded the daily build, ran it live and I did what you suggested. When I was done I hit the Back button, but nothing happened. I logged out and back in, but no change. Do I need to restart the computer at this stage? Sep 18, 2011 at 18:48
  • hmmm - I have my doubts that you can do this via a live CD.
    – fossfreedom
    Sep 18, 2011 at 22:31
  • 1
    I don't see how I should apply this setting. I uncheck the box, set the refresh rate to 75 Hz and all I can hit is the Back button at the bottom left. When I come back, it's 50 Hz again. Oct 17, 2011 at 21:03
  • Are you now using an installed version - or still running a live CD?
    – fossfreedom
    Oct 17, 2011 at 21:05
  • 1
    This answer is not working as I expected .It shows Refresh rate for OUR SATISFACTION, but after i reboot , setting is reset to 60HZ
    – Pratik
    Feb 13, 2015 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.