0

Internet over router using ethernet cable worked fine before I did any manipulation with PPPoE on my computer.

After configuring PPPoE and testing some things I had to rollback configurations added by pppoeconf so I could use wired connection over router.

I found that I have to edit /etc/network/interfaces and /etc/NetworkManager/NetworkManager.conf. So I have now:

cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

and

cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

no-auto-default=my mac address here,

[ifupdown]
managed=false

I also removed PPPoE config from /etc/ppp/peers which was added by pppoeconf.

Now system automatically switches connection from wireless to wired and IP address is obtained from DHCP, when ethernet cable is plugged, as it was before. But I can't ping anything outside LAN. Sometimes I get random package received message like 1 of 100. For example:

PING google.com (94.137.63.215) 56(84) bytes of data.
64 bytes from cache.google.com (94.137.63.215): icmp_seq=23 ttl=60 time=6.65 ms
--- google.com ping statistics ---
27 packets transmitted, 1 received, 96% packet loss, time 26042ms
rtt min/avg/max/mdev = 6.655/6.655/6.655/0.000 ms

Wireless connection works fine, and wired connection on other computer works fine too.

  • Try replacing your Ethernet cable or connecting to a different port on your router. This sounds like a hardware problem. – Elder Geek Mar 13 '15 at 16:47
  • @ElderGeek I already tried other ports, and cable is fine, since other computer works with this cable and if I configure pppoe it just works fine, so I'm sure it's a software issue. As I wrote above local addresses are pinged fine. – Dmitriy Mar 13 '15 at 17:41
1

I solved this myself. Not sure what happened to router or my ethernet config, but it now don't work when router ISP port uses same MAC address as my ethernet port does. So I changed MAC address of ethernet, and now internet resourses are available. Can't change MAC address of ISP port, since provider binded it and I can't reset binded MAC addresses during this month due to provider's limitation.

BTW, my router is Keenetic Giga II, firmware v2.04(AAFS.7)C5.

From lspci -knn | grep "Eth\|Net" -A2 :

Ethernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10) Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:10e9] Kernel driver in use: alx

0

It once happened to me . What I did is to turn ethernet automatic.
You can see a picture here :
enter image description here
After trying many things as you did , enable the auto ethernet worked for me .

  • Thanks for your response, but it did not help – Dmitriy Mar 13 '15 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.