So I have just bought a HP stream 11 and installed Ubuntu Gnome 14.10. I am having trouble with the touch pad it is expressing this functionality

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1409192

  • An optical USB mouse plugged into the laptop works normally IF the trackpad mouse buttons are never used.
  • Clicking the left or right button sections of the trackpad does NOT result in any left or right click action occurring (e.g. opening right click menu).
  • Using basic click touchpad gestures that are on the main section of the trackpad work normally (i.e. single finger tap to left click, two finger tap to right click, two finger drag to scroll).

I realise that this is a bug but in this review on Amazon http://www.amazon.com/review/R28HR668I6LU8Y/ref=cm_cd_pg_next?ie=UTF8&asin=B00NSHLUBU&cdForum=Fx32V5DBEJH4RUL&cdPage=3&cdThread=Tx1I5CUWGAIAGT5&store=pc#wasThisHelpful

The reviewer talks about how clicking the "Enable Mouse Clicks With Touchpad" solves the problem. I can't find this option in gnome I presume that he found the button in Unity.

Any help much appreciated.

I wasn't sure about that option myself.

what fixed the touchpad for me was upgrading the kernel. I think someone mentioned 3.16 fixed it (or not) but I went ahead and jumped to 3.19.

Warning - I have terrible wifi issues. it disconnects every few minutes. I hope it's not a result of this upgrade as the touchpad is terrible without it.

I don't want to give any false or misleading information so just do a little research on how to upgrade your kernel, its a very simple process.

once the touchpad is working you can do two-finger scrolling and two-finger tap to right-click. The mechanical buttons will also function without breaking everything.

  • 3.16 seems to have fixed it – JGreen Apr 26 '15 at 19:07

This worked for me as well. Click now works and right click works with click and hold. It will take a little getting used to but my clicking didn't work at all before.

https://help.ubuntu.com/stable/ubuntu-help/a11y-right-click.html

As a note, I updated Ubuntu to the latest version recently and the kernel updated and I started having wifi issues. I rolled back to kernel 4.2.0-37-generic with Ubuntu 15.10 and have a perfectly working HP Stream 11 with all hardware working, wifi, touch pad (including click/drag) etc.

To get here I started with 14.10 64bit which was recommended via a YouTube video https://youtu.be/mbglTmowRK4 and ran the standard ubuntu updates.

On a side note, I also installed TLP for power management. Comp stays cool and is quick. Faster in most cases than Windows 10 imho.

Hope this helps!

I had the same problem and magically, the simulated secondary click seems to work -- I can now 'right click', and it re-enables my drag/drop function, which was hanging before. I have an HP Stream 11, running Ubuntu 15.10. No other issues so far.

https://help.ubuntu.com/stable/ubuntu-help/a11y-right-click.html

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.