0

Trying to get a thin client to boot from my VirtualBox installed with 14.04.2 and LTSP. Here's what is happening:

  1. Thin vm client powers on and gets assigned 192.168.9.20 by LTSP server
  2. Thin client then is able to grab the pxelinux.0 file from LTSP server

    pxelinux.cfg/default       ok
    
  3. Screen goes blank for a few moments

  4. Then i get this error:

    Error: Socket failed: Connection timed out
    Exiting. 
    

Thin client finally defaults into BusyBox.

Not sure if it matters, but, when I do an ifconfig from (initramfs) prompt, i see that the ip address is now 192.168.9.101 which is odd.

Edit

Kind of flailing around now, but, when I tried to (initfamfs) wget ftp://192.168.9.10, I get wget: can't connect to remote host (192.168.9.10) where 192.168.9.10 is the LTSP server.

Any suggestions are appreciated.

0

After some guidance on LTSP IRC (special thanks to alkisg), I figured out the issue. Ultimately, it turned out that my VirtualBox host-only network was doing something weird. It didn't actually disable the virtual dhcp server when I unchecked the box.

Force VirtualBox Manager to disabled dhcp

Some other people had the same issue: https://forums.virtualbox.org/viewtopic.php?f=1&t=32201

  1. On your host machine, list the running dhcp servers: VBoxManage list dhcpservers
  2. Note the name of the dhcp service you want to disable, then VBoxManage dhcpserver remove --netname {name of dhcp server}. In my case: VBoxManage dhcpserver remove --netname HostInterfaceNetworking-vboxnet1
  3. Do another VBoxManage list dhcpservers to ensure it's actually gone.

Debugging steps

On the thin server, modify the pxe boot command issued to the thin client located in /var/lib/tftpboot/ltsp/{architecture}/pxelinux.cfg/default where {architecture} is either amd64 or i386. Although the config file says not to edit anything because your changes will be overwritten, it's fine to do so as we're just testing. You'll want to locate the correct section that pertains to your LTSP setup (whether NBD or NFS) and make it look something like the following n.b. the break=mount:

label ltsp-NBD
menu label LTSP, using NBD
kernel vmlinuz-3.13.0-46-generic
# append ro initrd=initrd.img-3.13.0-46-generic init=/sbin/init-ltsp quiet splash root=/dev/nbd0
append ro initrd=initrd.img-3.13.0-46-generic init=/sbin/init-ltsp root=/dev/nbd0 break=mount
ipappend 2
  1. First, from your LTSP server tail the log to see what errors come up: tail /var/log/syslog -f.

  2. Now, reboot the thin client and you should be presented with an (initramfs) command prompt.

  3. Check the ip address of your machine to make sure your on the correct network by running: ifconfig.

  4. Check the network configuration provided by the LTSP server: cat /run/net-eth0.cfg. (For me, I noticed that the ip address assigned to ROOTSERVER was not the same as that of my LTSP server.)

  5. Check to see if you can manually mount and boot the image from the LTSP server: nbd-client {ltsp server ip} -N /opt/ltsp/{architecture} /dev/nbd0.

As I said, ultimately, something funky was going on w/ my vm host-only network and after powering off the server and client and restarting, it all worked.

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.