2

Ubuntu 14.04, HP ZBook GNU Emacs 23.1.1 (x86_64-redhat-linux-gnu, GTK+ Version 2.18.9)

When I'm typing into a buffer, or just moving the cursor with ^N,^P, etc, often emacs pops up a "buffer menu" window(this is a separate X window). Why does this happen and how can I stop it?

3

2 Answers 2

2

I just had the same problem. You can figure out what keystrokes just took place (after dismissing the window) with "C-h l". In my case it was C-mouse-1 because on my laptop the mouse pad is right where I like to rest my palms when typing. Even though I use a regular mouse, it still processes the mouse pad. You can disable it by using global-set-key to make C-mouse-1 undefined (simply provide no new setting).

1

Quick workaround: Before typing in an emacs window that displays this behavior, move the mouse cursor to a region of the window where Ctrl-mouse-1 has no effect (eg. the top "window handle" region. Now you can type without fear of having the buffer menu popup on you every so often. (I hope).

The permanent fix is somewhere outside of emacs, either in the window manager, or X11 configuration. By default, emacs has variable: make-pointer-invisible set to t (true) which will cause proper behavior when typing. Something external to emacs is causing emacs to only sometimes hide the pointer when typing.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.