1

For some reason the system date on my system changes itself to the wrong date. For example, while writing this the Ubuntu clock showed the date as 15/03/2015 and the time as 4:58 AM, but the actual date and time was 12/03/2015 at 8:58 PM. I have tried manually setting the time and date but after several reboots the clock changes again. The BIOS time and date on my system is correct and I do not dual boot, Ubuntu 14.10 x64 is my only operating system. I have looked on other forums for others with a similar problem but none of the solutions have fixed it. I have also tried reinstalling Ubuntu but the problem still persists. Any ideas how I can fix this?

Output from sudo hwclock --debug (clock correct at the moment, will update again next time it changes):

hwclock from util-linux 2.25.1    
Using the /dev interface to the clock.  
Last drift adjustment done at 1426437469 seconds after 1969   
Last calibration done at 1426437469 seconds after 1969  
Hardware clock is on UTC time  
Assuming hardware clock is kept in UTC time.  
Waiting for clock tick...  
...got clock tick  
Time read from Hardware Clock: 2015/03/12 21:25:26  
Hw clock time : 2015/03/12 21:25:26 = 1426195526 seconds since 1969  
Thu 12 Mar 2015 21:25:26 GMT  -0.469705 seconds

Edit: The date has changed itself again. The clock reads "Mon Mar 16 2015 2:58 PM". I have re-ran sudo hwclock --debug and got this output:

hwclock from util-linux 2.25.1
Using the /dev interface to the clock.
Last drift adjustment done at 1426437469 seconds after 1969
Last calibration done at 1426437469 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
select() to /dev/rtc to wait for clock tick timed out...synchronisation failed
  • Welcome to Askubuntu.com! Please edit your question and add the output of sudo hwclock --debug. – Jos Mar 12 '15 at 21:17
  • Yes, that is correct and consistent. Would be interesting to see whether the hardware clock changes or the time zone translation, at the time things go wrong. – Jos Mar 12 '15 at 21:42
  • 1
    Or you are getting confused by a two digit year and the day. Turn year off in the clock settings in that case. – ubfan1 Mar 12 '15 at 21:56
  • Seems like a hardware problem in your Reat Time Clock... What's the output of ll /dev/rtc – Fabby Mar 15 '15 at 17:30
  • lrwxrwxrwx 1 root root 4 Mar 23 2015 /dev/rtc -> rtc0 – Luke Parker Mar 20 '15 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.