8

I am not able to install wireless card driver on Ubuntu? I tried to install it manually but not able to install?

1
  • All the commands here will not work until you turn off your secure boot from boot menu. This prevents system from installing drivers Jan 9, 2019 at 7:36

5 Answers 5

13

Sorry that I have to add this as an answer, as I don't have rep to comment yet. Thanks to chili555 reply and racar comment I now have the PCE-AC68 working on my system, Ubuntu 15.04 on mobo ASUS A88XM-A by

sudo apt-get install bcmwl-kernel-source
sudo modprobe wl
sudo reboot

I wanted the card as I've upgraded my cable modem + wifi router to Telstra Gateway Max (rebadged Netgear) which supports dual band wifi. Link speeds specified as 216/292 Mbps. It's probably not ideally set up yet as I'm only getting about 30 Mbps - I note that it's 802.11abg connection from iwconfig:

wlan1     IEEE 802.11abg  ESSID:"Telstra226B"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 40:5D:82:47:F4:66   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

But at least it is working now, and faster than my old Netgear WN111 usb plugin :) So thank you again.

8

Please run the command:

lspci -nn

Is your device this?

Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)

If so, it uses the driver bcmwl-kernel-source. If you still have the install DVD or USB, then you can find it and its prerequisite there. Navigate to pool > restricted > b > bcmwl and drag and drop the deb file to your desktop. Now navigate to pool > main > d > dkms and drag and drop dkms to your desktop. Now install both with:

cd ~/Desktop
sudo dpkg -i *.deb

Load the driver:

sudo modprobe wl

Your wireless should now be working. If it not as I described, please post your finding and I will edit my answer to propose a different solution.

3
  • 1
    Thanks, I found here the .deb file version 6.30.223.248 (ftp.psu.ru/linux/ubuntu/pool/restricted/b/bcmwl). And did exactly what you said, everything works fine now. I am running Ubuntu 14.04 by the way.
    – Devid
    Apr 20, 2015 at 11:55
  • 1
    since on the DVD i didn't find any drivers (only windows), i used sudo apt-get install bcmwl-kernel-source
    – racar
    Jun 10, 2015 at 0:35
  • You sir, are a gentleman, and a scholar. You guard the night with your wisdom. You are ever so gentle, and perfect. But really THANK YOU!!! I thought all hope is lost! PPl on amazon were saying it wont work ever!
    – agrublev
    Apr 13, 2017 at 18:07
7

I used this method:

Go to Settings > Software & Updates > Additional Drivers

It loads for a few minutes and then shows your wifi device (Broadcast name) and then you can enable it.

Then you can sudo apt-get update. It works for me.

0

I'm using the same Wifi Adapter and got it to work as chili555 mentioned (could not comment yet). But on a default installation of Ubuntu there's a package missing which is mandatory. This is the DKMS package. So you need to install the DKMS package first before installing the driver package like Chilli555 explained.

sudo apt-get install dkms

Working on Ubuntu 14.10 and using the 5Ghz band it's performance is similar to what it is under Windows. On my internet connection I'm getting 200+ Mbit/s

0

Install ndiswrapper

sudo install ndiswrapper-common ndiswrapper-modules-1.9 ndiswrapper-utils-1.9

Install the WiFi driver (from Windows):

sudo ndiswrapper -i yourdriver.inf

Check the driver is working:

sudo ndiswrapper -l

Load the module:

sudo depmod -a

sudo modprobe ndiswrapper

Configure modprobe so that it loads ndiswrapper:

sudo ndiswrapper -m

Edit the modules to add ndiswrapper at the end:

sudo -H gedit /etc/modules

Remember to add ndiswrapper at the end.

Hope you now have your WiFi up and working!

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.