7

My upstart job which configured my trackpoint sensitivity (Values 255, 255) does not work anymore. How can I get equivalent behaviour with systemd?

3
  • 1
    Accepted answer no longer work on Ubuntu 15.10 for me running Lenovo Thinkpad X220. Solution proposed here works just fine: askubuntu.com/a/689741
    – m1lhaus
    Jan 11, 2016 at 20:25
  • Let's talk about this in the AU chat room ;-)
    – Fabby
    Jan 12, 2016 at 10:39
  • @m1lhaus I improved the accepted answer here, and just tested it on 16.04. It works for me.
    – Anon
    Jan 12, 2016 at 11:10

2 Answers 2

14
  1. Ctrl + Alt + T (Opens Terminal)
  2. sudo -i gedit /etc/tmpfiles.d/tpoint.conf
  3. Add the following lines (*):

    w /sys/devices/platform/i8042/serio1/speed - - - - 255
    w /sys/devices/platform/i8042/serio1/sensitivity - - - - 255
    w /sys/devices/platform/i8042/serio1/inertia - - - - 6
    w /sys/devices/platform/i8042/serio1/press_to_select - - - - 0
    
  4. Adjust the numbers to your liking. Higher = More Fast/Sensitive -- press_to_select is for tapping on the trackpoint to simulate a click. 1 to enable.

  5. Save, Exit.

  6. For these changes to take effect before next reboot (see), run

sudo systemd-tmpfiles --prefix=/sys --create

(*) Thinkpad X1 Yoga Or Thinkpad W530 users will need to modify slightly:

w /sys/devices/platform/i8042/serio1/serio2/...

You can find out the exact path on your device via:

find /sys/devices/platform/i8042 -name name | xargs grep -Fl TrackPoint | sed 's/\/input\/input[0-9]*\/name$//'

Personal Recommendation

  • Use the highest settings (255,255)
  • Go into Mouse and Touchpad settings and set that bar value to the lowest value.

After you get used to it, your finger will have to do much less effort into moving the cursor and will greatly reduce any strains or pains in your finger.

6
  • 2
    Running graphical applications as root is not recommended. Use sudo -i or gksudo.
    – Seth
    Apr 19, 2015 at 4:39
  • gksudo is no longer installed by default
    – Anon
    Apr 19, 2015 at 5:02
  • 1
    I'm aware of that but plain sudo is not a good alternative.
    – Seth
    Apr 19, 2015 at 5:03
  • 1
    Unfortunately this solution doesn't seem to work with 2017 ThinkPads (mine is an X1c5), which have - yet again - different input devices hardware. Anyone knows how to tweak trackpoint sensitivity for those?
    – sxc731
    Oct 30, 2017 at 4:12
  • 1
    @Akiva thanks for the suggestion. Alas this doesn't work; I get Permission denied trying to run echo 175 > /sys/devices/platform/i8042/serio1/serio2/sensitivityas root. Quick inspection of the filesystem reveals these files (speed, sensitivity etc) are gone. find doesn't find them anywhere under /sys/devices/platform/i8042. See also ubuntuforums.org/showthread.php?t=2366851
    – sxc731
    Oct 30, 2017 at 4:23
0

For Thinkpads circa 2019, ( I have a Thinkpad x390 Yoga ) -- the following solution worked for me:

  1. Find the device name: TPPS/2 Elan TrackPoint by running:
xinput --list --short

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Finger touch      id=9    [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Pen stylus        id=10   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎜   ↳ TPPS/2 Elan TrackPoint                    id=15   [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Pen eraser        id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=11   [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated I           id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=16   [slave  keyboard (3)]
    ↳ Apple, Inc. USB-C to 3.5mm Headphone Jack Adapter id=18   [slave  keyboard (3)]

  1. set the sensitivity to max with this command:
xinput --set-prop "TPPS/2 Elan TrackPoint" "Coordinate Transformation Matrix" 1 0 0 0 1 0 0 0 1

You can use 0.5 if you want to halve it. Most of those 0's have to do with direction.

  1. Go to your mouse settings and do something like this:

enter image description here

And that has given me the best sensitivity thus far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.