8

Wired internet works fine in Windows 7 Pro and "Try Ubuntu" 14.04.2 LTS booted from disk and in the installed Ubuntu, but stops working after booting Windows and then Ubuntu. I've seen numerous different problems and solutions to wired internet not working in Ubuntu 14.04, but none of them seem to apply to this case. I updated the NIC driver e1000e to the latest version (3.1.0.2), but this did not solve the problem. Again here is the pattern:

⠀Boot to Windows 7 Pro - wired internet works
⠀Boot from disk "Try Ubuntu" 14.04.2 LTS - works
⠀Boot to installed Ubuntu - works
⠀Boot to Windows - works
⠀Boot to installed Ubuntu - doesn't work

I've tried this sequence a few times and it is consistent. What to check?

Output of ifconfig below:

eth0      Link encap:Ethernet  HWaddr 98:90:96:c4:6b:06  
          inet addr:192.168.1.145  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::9a90:96ff:fec4:6b06/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:119357 errors:0 dropped:72 overruns:0 frame:0
          TX packets:604 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10287715 (10.2 MB)  TX bytes:91839 (91.8 KB)
          Interrupt:20 Memory:f7800000-f7820000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:463 errors:0 dropped:0 overruns:0 frame:0
          TX packets:463 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:36090 (36.0 KB)  TX bytes:36090 (36.0 KB)
  • 1
    Do you also get this behaviour when you fully shut down the computer when shutting down Windows instead of rebooting and remove all batteries? (UPS if a PC and internal battery when a laptop) – Fabby Mar 16 '15 at 14:23
  • Dual-booting Windows 10 and Ubuntu 16.04, and experiencing the exact same problems as you. Glad to know I'm not the only one, would love to find the problem and solution. – gromit190 Jun 11 '16 at 11:38

10 Answers 10

10

Also bothered by this issue for a week before finally finding the solution.

The problem is caused by that, the Windows driver configures the ethernet card to a specific state while Ubuntu is trying to initialize the card from fresh and fails.

Solution:

  1. Download the newest driver from the Intel site.
  2. Remove any existent Ethernet card driver on Windows and install the downloaded driver.
  3. Go to "Power management" tab in the ethernet card configuration dialog, uncheck all options and click OK.

The first time you do this you will have to wait for some time before the Internet connection is re-established. After the Internet connection is up, reboot into Ubuntu and test. Everything should be fine now.

  • Thx. FYI: I tried downloading from my motherboard's download site as I was thinking they would be similar (or at least not the default windows ones), but that didn't work. Not realizing this I then fixed with with the 'reset pci device in linux' method described by multiple other answers, it was a little bit different on my manjaro distro. Then tried this again with latest drivers from the intel site, which now also works. – Emile Vrijdags Dec 30 '17 at 15:25
3

I experienced similar problems when dual booting machine with MS Windows 7 Enterprise and Ubuntu 14.04.

Wired network does not work in Ubuntu when I restart from MS Windows7 and then start Ubuntu.

After using MS Windows 7 I have to shutdown first before using Ubuntu.

  • This worked for me with Windows 10 and Ubuntu 14.04.4 LTS, thanks! – nukeguy Mar 2 '16 at 22:04
  • This was the solution for me aswell. Windows 10 and Ubuntu 16.04. – gromit190 Jun 9 '16 at 13:56
3

This problem seems to be some sort of low level setting that Windows can leave on the network card that Ubuntu can't restart correctly. I had the same problem with the Intel i217-V networking chip. The solution I have is that on Ubuntu start-up, I reset the chip. So now works even if closed down on Windows. You'll need to find which PCI device is your card and then reset it as below.

To list PCI devices enter lspci in the terminal, and and you'll get a list -look for the line with your Ethernet controller. mine shown below:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 05)

So I added to /etc/rc.local

echo 1 >/sys/bus/pci/devices/0000:00:19.0/reset
exit 0

(source – I couldn't understand the script, and this seemed simpler.)

2

Some settings in Windows may prohibit internet connecting in Ubuntu. I disable WOL (wake-on-lan) of power management in Wiondws 8 and then it works in Ubuntu.

2

at a recent case this happened also after an update to kernel 4.4.0.72 who made the bug of after booting from a Windows 10 dual-boot, the wired network at next Ubuntu 16.04 boot did not work, even with all settings ok;

using the older kernel at boot made it work without any changes, at this case 4.4.0.71 was Ok, going from the boot "Advanced options for Ubuntu" menu entry.

I could then fix it by editing /etc/grub.d/10_linux_proxy, deleting 4.4.0.72 files from /boot and using grub-mkconfig and update-grub

this approach however did not worked with other PC with the same bug, who had kernel 4.4.0.21 before 0.72 updated; so this is just informative.


on an Ubuntu 16.04 with wired ethernet locked after coming from Windows 10 dual-boot, the following script/steps at command-line set it working again:

this script author is jnko from an article at bbs.archlinux.org/viewtopic.php?pid=1575719

#!/bin/bash
#Get the PCI-Address of network card (Caution: This works ONLY with ONE NIC)
PCI=`/usr/bin/lspci | /bin/egrep -i 'network|ethernet' | /usr/bin/cut -d' ' -f1`
PCIPATH=`/usr/bin/find /sys -name *\${PCI} | /bin/egrep -i *pci0000*`
echo "PCI    =$PCI"
echo "PCIPATH=$PCIPATH"
ls -la $PCIPATH
/usr/bin/logger -t "ResetNIC" "Resetting PCI NIC ${PCIPATH}"
#Reset the PCI Device completely (like Power-ON/Off)
echo 1 >${PCIPATH}/reset

then after running it:

service network-manager restart

please wait about 30 seconds after this last step


in case of desperation, just shutdown your system, and remove for a few seconds the electric power plug; not a joke: this will release the lock windows 10 make to the ethernet hardware, and Ubuntu will have net again.


also, if you remember when at Windows 10, disabling the ethernet interface before rebooting will also avoid this lock at next Linux boot.


while I could not believe this at first, it is true: this bug only happens when one restarts Windows to Linux; if it is done a shutdown at Linux, or Windows is ended down to shutdown the PC, this does not happen. 8-]

2

I was also having this issue that started with a new network router dual booting Windows 7 and Kubuntu 18.04.

For me, it was a DHCP issue, and the easiest solution was to have Kubuntu use a cloned MAC address different than the one windows uses.

Should be an option for your network connection under network settings.

In Kubuntu, search for connections:

choose connection -> wired tab -> cloned MAC address -> random -> apply

This should do the trick.

1

Maybe this could solve your problem

The problem is described here: https://sites.google.com/site/easylinuxtipsproject/internet#TOC-No-wired-or-wireless-internet-on-a-dual-boot-computer

This may be due to a flaw in Windows, which can be repaired easily.

If you have a dual bootable PC with Windows, and you've just used Windows, you may not get an IP address after a reboot in Linux. And so no internet connection.

This has the following reason: every network card has a unique MAC address. This address is ingrained in your NIC. The DHCP server in your router remembers this MAC address.

When you access the internet in Windows and then reboot in Linux, in many cases you'll get no IP address from the DHCP server in your router. Because this server will recall that it previously issued an IP address for that very same MAC address, and won't issue a new one.

You can solve this by forcing Windows to release the IP address, before you reboot the PC. By the way: Linux by default does release the IP address on shutdown. So a reboot from Linux into Windows causes no problems.

Tip: Did you forget to force Windows to release the IP address, and you don't want to boot Windows to do it as yet? Then simply boot Ubuntu or Linux Mint twice in a row. After the second boot of Ubuntu or Mint you can probably connect.

A. Manual method 1. Open a DOS window in Windows

Windows XP: Start - Programs - Accessories - Command Prompt

Windows 7: Start - All Programs - Accessories - Command Prompt

  1. Type: ipconfig /release

(note the space between ipconfig and /release)

And press Enter.

B. Semi-automatic method By means of a shortcut on your desktop, you can apply a semi-automatic solution for this.

  1. Open Notepad Windows XP: Start - Programs - Accessories - Notepad

  2. type the following text: ipconfig /release

  3. Save this text file as release.bat and place it on your desktop. Now you can always simply double click this file, before you exit Windows.

As I said, Linux releases the IP address by default on shutdown. So a reboot from Linux into Windows causes no problems.

  • Welcome to Ask Ubuntu! Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. – Thomas Ward Aug 4 '16 at 15:06
1

ccy's suggestion to turn off "Wake-on-LAN" works. We use "Wake-on-LAN", so we adopted ccy's solution after finding a workaround. Step 3 of Zhou's solution has the same effect, of course. Otherwise, ...

Upgrading to the latest driver from Intel didn't make any difference for us, as the last 3 versions since 2015 seem to work the same.

Originally we had to shutdown windows then unplug both the power cord and the network cable for 20 seconds, then power on and boot into Ubuntu 16.04, and then the network was okay. Unplugging for 5 seconds did not work. Unplugging only the power cord or only the network cable did not work.

Maybe the order of connecting cables was important: We unplugged the network cable first and then the power cord. Waited for 20-30 seconds, then plugged the power cord in first, then the network cable.

Dell Precision 7810 with Windows 10 and Ubuntu 16.04, using a static IP, not DHCP.

  • user477411 posted a similar answer and it got downvoted, but it starts to be more convincing when multiple users post the same thing. – karel Mar 4 '17 at 0:10
0

The only thing you need to do is remove the power cable of your system unit and plug it again after 30secs then turn on your computer. that's all.

0

I had the same trouble - adding nmcli c up YOURSSID to my startup applications solved it for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.