I have Ubuntu 11.04 on Thinkpad X41 and have been using it for a couple of months. From time to time System Update used to run and show me a list of recommended updates. Finaly, yesterday I accepted all of them and after some time I had it all 'updated'.

Today, after I restarted my laptop, I realized that my passphrase doesn't work anymore!! At first I thought I have real memory problem, but then I recalled that recent update.

When I run it in recovery mode it looks like that:

Unlocking the disk /dev/disk/by-uuid/[...] (sda5_crypt)
Enter psasphrase: ****************************
[timestamp] Intel AES-NI instructions are not detecred.
No key available with this passphrase.
cryptsetup: cryptsetup failed, bad password or options?

I'm desperate to get all my files back, do you have any idea how to help with that? I guess there might be something about this Intel AES-NI but no idea how to fix it.


The Intel AES-NI instructions are not present in all CPUs. That warning shows up on my LVM every time I boot and is not the reason, why your LVM cannot be unlocked.

Do you have a custom keyboard layout defined? Not sure, whether this also applies to LVM, but TrueCrypt always uses US keyboard layout on startup. Maybe your keyboard layout was switch during update due to some overwritten config file?

If nothing helps, try booting from a Ubuntu USB stick oder a Ubuntu CD and try mounting your LVM volume in the live system. But don't use the 11.04 image: I think I remember trying to change my LVM using that one and LVM didn't install on that live image.

  • Thank you for your answer. I tried to mount from live cd and it still doesn't work. Do you know is this possible that a passphrase changed? I really don't whether I should look for technical explanation or go to see a doctor.. – HeyMike Sep 1 '11 at 18:41
  • Usually your pass phrase should not change. I have heard of cases, where data corruption makes the LVM unreadable, so that basically all data is lost. Since this isn't something I have encountered myself, I don't know what the symptoms for this problem are, but I guess your problem description might fit. If that is really the case, you are probably screwed. Another suggestion I came upon: Try booting an older kernel and see whether it works with that one. – ChrisiPK Sep 1 '11 at 21:03

I had the same problem and I still have the problem with newer kernels. So, stick with kernel. After that, all Ubuntu kernels don't accept my passphrase.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.