2

I've installed 3 vm's on virtual manager, I've successfully mounted a file system(mapped) with the host but when I try to mount the file system with the second vm and reboot it's giving me the error as above. I've tried nobootwait in /etc/fstab it's not helping and file system is not mounting.

My contents of /etc/fstab on second vm:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/vda1 during installation
UUID=43ac7681-6e1c-499f-8059-f5b8f3082916 /               ext4    errors=remount-ro 0       1
# swap was on /dev/vda5 during installation
UUID=2f00440c-d28c-41ba-8b8a-75e816dea4a6,nobootwait none            swap    sw              0       0
g2   /mnt    9p  trans=virtio,version=9p2000.u,rw    0   0

2 Answers 2

2

Remove nobootwait from the following line

UUID=2f00440c-d28c-41ba-8b8a-75e816dea4a6,nobootwait none            swap    sw              0       0

also remove the line

g2   /mnt    9p  trans=virtio,version=9p2000.u,rw    0   0

add the following line to the file /etc/rc.local

mount -t 9p -o trans=virtio,version=9p2000.L,rw g2 /mnt

This will execute this command when you start the ubuntu vm and mount the filesystem.

0
1

There is an error in your fstab. The line

UUID=2f00440c-d28c-41ba-8b8a-75e816dea4a6,nobootwait none  swap    sw           0       0

should be

UUID=2f00440c-d28c-41ba-8b8a-75e816dea4a6 none            swap    sw            0       0

with a space after the disk ID. If you want to add the nobootwait option, it should go after the sw:

UUID=2f00440c-d28c-41ba-8b8a-75e816dea4a6 none            swap    sw,nobootwait 0       0
1
  • I corrected fstab as u said but it's giving me the same error while booting. File systen is not mounted! I used this to mount first vm guest# mount -t 9p -o trans=virtio,version=9p2000.L,rw share /mnt I used this to mount second vm guest# mount -t 9p -o trans=virtio,version=9p2000.U,rw g2 /mnt I've changed as above in fstab Mar 12, 2015 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.