0

How can I turn off the trackpad of a 2015 ThinkPad Yoga 12 running Ubuntu 15.04 with Linux kernel 3.19.0-7-generic without turning off the dedicated TrackPoint buttons? The input devices are listed as follows:

$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 EC Pen stylus                 id=11   [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 EC Pen eraser                 id=15   [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=13   [slave  pointer  (2)]
⎜   ↳ SYNAPTICS Synaptics Touch Digitizer V04   id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=14   [slave  keyboard (3)]

The properties of the device "PS/2 Synaptics TouchPad" are as follows:

$ xinput list-props "PS/2 Synaptics TouchPad"
Device 'PS/2 Synaptics TouchPad':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (265): 0
    Device Accel Constant Deceleration (266):   1.000000
    Device Accel Adaptive Deceleration (267):   1.000000
    Device Accel Velocity Scaling (268):    10.000000
    Device Product ID (257):    2, 1
    Device Node (258):  "/dev/input/event4"
    Evdev Axis Inversion (269): 0, 0
    Evdev Axes Swap (271):  0
    Axis Labels (272):  "Rel X" (149), "Rel Y" (150)
    Button Labels (273):    "Button Left" (142), "Button Middle" (143), "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down" (146), "Button Horiz Wheel Left" (147), "Button Horiz Wheel Right" (148)
    Evdev Scrolling Distance (274): 0, 0, 0
    Evdev Middle Button Emulation (275):    0
    Evdev Middle Button Timeout (276):  50
    Evdev Third Button Emulation (277): 0
    Evdev Third Button Emulation Timeout (278): 1000
    Evdev Third Button Emulation Button (279):  3
    Evdev Third Button Emulation Threshold (280):   20
    Evdev Wheel Emulation (281):    1
    Evdev Wheel Emulation Axes (282):   6, 7, 4, 5
    Evdev Wheel Emulation Inertia (283):    10
    Evdev Wheel Emulation Timeout (284):    200
    Evdev Wheel Emulation Button (285): 2
    Evdev Drag Lock Buttons (286):  0
  • sry, not directly related to your question but I could not find a way to pm you. I started a Linux thread for the TP Yoga if you are interested in contributing your experience so far. Maybe you can find also help there as more people are getting this device. cheers – joelostblom Mar 26 '15 at 21:04
  • Hey, thanks for that! I'll pop with any details I can. I'm amused that you mentioned spin, because I wrote the damned thing. :) – d3pd Mar 26 '15 at 22:33
  • Great! And thanks for writing spin =) I think it will be very useful for me as soon as I have sorted out the screen suspend issues. – joelostblom Mar 26 '15 at 23:08
0

And now I actually remember reading something that might help you directly. It is from djahma's response #6 in the kubuntu thread and it works for me to disable areas of the trackpad. Just make a copy of /usr/share/X11/xorg.conf.d/50-synaptics.conf and name it 60-synaptics.conf to have higher precedence. Then add the following two lines

Option "AreaTopEdge" "30%"
Option "AreaBottomEdge" "80%"

so that the second last section of the file reads

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
    Option "AreaTopEdge" "30%"
    Option "AreaBottomEdge" "80%"
EndSection

That disabled the top 30 % and bottom 20 % for me. I imagine you can just make it 50/50 or 100/0 to disable the entire thing. Reboot and enjoy! (i cant get three finger click to work using his suggestions though...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.