0

So here's the situation: I created a VM in VMWare workstation 9, set its network adapter to VMNet0 (configured in auto-bridging with the host physical interface) and then in ubuntu I set up the network configuration to have a static IP address (using the visual network manager).

The host machine (windows if that matters) has IP configuration:

  • ip 192.168.0.x (dhcp assigned)
  • gw 192.168.0.1
  • ns 8.8.8.8

the guest machine instead

  • ip 192.168.0.200
  • gw 192.168.0.1
  • ns 8.8.8.8

Now on the virtual machine the dns resolution works fine, I can ping both domain names and external IPs BUT when I try to download anything it looks like I cannot establish a connection with the server... Trying to run apt-get update for example will simply hang and after a while I would receive errors such

Cannot initiate the connection to it.archive.ubuntu.com:80 (2001:760:ffff:b1::45). - connect (101: Network is unreachable) [IP: 2001:760:ffff:b1::45 80]

Now it may look like from this log that the error is an IPv6 error but after disabling completely IPv6 the connection still hangs with this error:

Err http://it.archive.ubuntu.com trusty-updates InRelease                      

Err http://it.archive.ubuntu.com trusty-backports InRelease                    

Err http://it.archive.ubuntu.com trusty Release.gpg                            
  Unable to connect to it.archive.ubuntu.com:http: [IP: 193.206.140.45 80]
Err http://it.archive.ubuntu.com trusty-updates Release.gpg
  Unable to connect to it.archive.ubuntu.com:http: [IP: 193.206.140.45 80]
Err http://it.archive.ubuntu.com trusty-backports Release.gpg
  Unable to connect to it.archive.ubuntu.com:http: [IP: 193.206.140.45 80]
0% [Connecting to security.ubuntu.com (91.189.88.149)]

Any idea of what I'm doing wrong? any help is very appreciated... Thanks!

2

Not really an answer (can't comment - must have 50 rep) but did you configure the gateway to forward traffic (other than ICMP) from the VM ?

  • Giving you an upvote, hopefully you will receive soon the 50points needed to add notes :) Now apart from that... Please consider me as an ignorant, I set up the gw as indicated in the thread and in no other place... Should I do something else? If it matters I also tried disabling the firewall (sudo ufw disable) but without any success... – Antonio E. Mar 12 '15 at 9:13
0

Ok I feel like a fool... Basically was the Avast firewall installed on the windows machine that was blocking the bridged connection... Once enabled the internet connectivity sharing there, BOOM, internet back in the guest...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.