0

I've brought new Lenovo Z5070 laptop with preinstalled FreeDOS. Afterward, I've installed Windows 8.1 on it with Legacy BIOS enabled.

I have to use Ubuntu in dual boot with it. I've shrink my C: partition with 30GB to install Ubuntu in the freed space.

When installing Ubuntu, the installer is not detecting the new partition. It shows the entire as 1TB HDD.

I've stopped fast boot in Windows. It's installed in legacy mode so there is no secure boot option. I want to know which point I'm getting wrong.

  • Post this: sudo parted -l from terminal in live installer. Since Windows is in legacy mode, you must install Ubuntu in Legacy/BIOS/CSM mode not UEFI. Best to use Something Else. How you boot installer UEFI or BIOS is how it installs. If booted & installed in UEFI mode you will erase Windows with conversion to gpt partitioning. askubuntu.com/questions/343268/… – oldfred Mar 11 '15 at 19:56
  • hey Thanks for the reply, i tried with legacy mode and select try Ubuntu during installation but still Ubuntu not detecting my previews installed windows 8.1 and it shows entire 1TB HDD! – mahendra_ms Mar 13 '15 at 16:12
  • Even with Something Else install option? Can you just partition / as ext4 and swap with gparted and then use Something Else to choose those partitions you have created in advance. Or have you used all 4 primary partitions that MBR(msdos) allows? The parted list will show existing partitions. – oldfred Mar 13 '15 at 17:54
0

I have successfully installed Ubuntu 14.04 in dual boot! There are several steps that I followed here:

  1. As I told you I have a disk with an MBR partition, but boot repair detected them as GPT. Actually that was stray GPT which may remain from a previously installed OS. That's why to wipe out them I used FixParts software with live Ubuntu and used the tutorial as described here: http://www.rodsbooks.com/fixparts/.

  2. Afterward, I tried to install Ubuntu but my allocated space was detected as "unusable space" rather then "free space" during the installation, because with an MBR disk we can do a maximum of 4 partitions and the drive that I shrank was C: having a primary partition! That's why I shrank D: drive having a logical partition with 30GB and installed Ubuntu in Legacy mode.

  3. After successfully installing Ubuntu I restarted my laptop, but I was not able to detect Windows 8.1 (all my data remained safe as it was earlier in Windows!) so in the terminal I ran the command: sudo update-grub and... it detected Windows 8.1. After restarting the laptop I got an option to select either of the two OSs. :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.