I recently reinstalled Ubuntu 14.04, I have a NVidia Quadro K1000M on my Elitebook 8570w. I have added this ppa:

sudo apt-add-repository ppa:xorg-edgers/ppa

And installed nvidia-346 nvidia-settings. Running nvidia-settings shows me this:


However, running sudo software-proprietry-gtk show me


NVidia-346 is not listed.

So am I still using the Nouveau drivers? If I pick any of the NVidia proprietry drivers from the list, rebooting will result in "System running in low graphics mode", "Could not detect display, graphics card etc." (How to fix "The system is running in low-graphics mode" error?).

How can I use the NVidia proprietry drivers?

  • See newer answer below... – Fabby Mar 14 '15 at 20:05

The correct answer is: The xorg-edgers repackage the binary proprietary NVidia driver as "X.Org X-Server Nouveau". So that's why you see what you see in the "additional drivers" screen.

Now to see the exact version of the NVidia driver you're using you have to start nvidia-settings as you did or go to a terminal and execute nvidia-settings --version

This means that the next time the xorg-edgers repackage the newer driver, it'll get updated automatically, contrarily to installing the NVidia binary driver.

| improve this answer | |
sudo apt-get install nvidia-346 nvidia-settings nvidia-prime
sudo reboot

Finally. This works for me after 2 days searching.

  • ThinkPad W530
  • Ubuntu 15.04
  • K1000M
| improve this answer | |
  • Doesn't work on Ubuntu 14.04 though :/ (no nvidia-346 nvidia package) – Franck Dernoncourt Nov 16 '15 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.