0

My problem is that I cannot set brightness using fn+arrows and any other way. I'm currently using elementary os base on 12.04 and that problem is not showing, but on every ubuntu with higher number I can not, in fact I cannot set on any distro whatsoever [I had try with newest: Fedora, Mint, Ubuntu, OpenSuse and Mint debian based]. Also installing propriertary driver does not help. Please if anyone had same problem share yours knowledge. [Sorry if my english is bad, not my first language]

Edit: I would not change my system if elementary OS base 12.04 had driver for may wacom device. Lenovo Z570 has 2 video cards, nvidia + intel

4
  • I am using Ubuntu 14.04 in my Lenovo Z560, but I never faced such problems. Try to keep your system up-to-date.
    – Sooraj S
    Mar 11, 2015 at 8:14
  • Thank you for comment. I always try to stay with newest, but only on elementary OS I can set brightness. Every newest linux i cant menage to figure out how to enable this.
    – user386891
    Mar 11, 2015 at 8:19
  • Have you tried Ubuntu 14.04 ?.....
    – Sooraj S
    Mar 11, 2015 at 8:24
  • Yes, as well as 14.04.2 and 14.10. Does not work
    – user386891
    Mar 11, 2015 at 8:27

2 Answers 2

0

Did you need to install any program on Windows before it worked? On my laptop the keyboard light does not work at all, since I need a Windows program called Lenovo Nerve Sense. For me at least, the is no way to fix this. If your fn+arrow up is firmware based, you should be good to go. The problem is that you cannot change the state of fn keys, so usually if an fn function doesn't work on Linux, you can't do anything about it as far as I know. I have multiple fn functions that doesn't work, like disabling the touchpad on the laptop or all the windows functions like flight mode, lockscreen etc.

2
0

Edit /etc/default/grub with any editor, ex:

sudo mcedit /etc/default/grub

Search GRUB_CMDLINE_LINUX_DEFAULT="..." and add acpi_backlight=none at end.

Run:

sudo update_grub

Reboot!

You must log in to answer this question.