Installing Wubi 11.04 over Win7Pro (64-bit) on a Dell Latitude E5520 has now taken over an hour to reach the halfway mark in the "Copying files..." stage. The hard drive appears inactive for long periods No network connection, Wifi is on and networks available, system is responsive. But just oh so slow. What gives?

Full story

I've finally unpacked my new Dell Latitude E5520. My first move was to install Windows 7 Pro (64-bit) from scratch, followed by Ubuntu using Wubi. I'm using Wubi because the system comes with three paritions (Recovery, OS, and something else - boot booster?) and I like having a data partition available so I can blank the OSes without having to restore my data. That brings the partition count to the maximum four. Besides, for similar reasons I've been using Wubi on my Eee 1015P netbook. Wubi makes so little impact that I've never gotten around to replacing it with a proper installation.

So, I downloaded Wubi and ran it while online. The Windows phase of the installation goes ahead without any problems at all. I selected a username and password, regular Ubuntu flavour, and assigned the maximum 30GB for the Ubuntu filesystem. I then reboot into Ubuntu by my own choosing. The Wubi install proceeds to "Copying files..." and copies the files. Slowly. Not just user-impatience slowly, really slowly. Getting to the halfway mark took over an hour, and there are long periods (nearly 15 minutes at one point) where there was no apparent hard disk activity. The HD light doesn't flicker and the fan switches off for a few minutes at a time. The system is responsive (I can move the cursor with the mouse or touchpad, for example), just nothing seems to be happening.

When I first tried this, I thought the installation had failed, so I hard-rebooted my machine back into Windows and removed Ubuntu. I then downloaded the ISO manually, unplugged the network, and tried Ubuntu again. Since I have more time to spare, I've left it longer, with the drop-down terminal section open to see if any errors were coming up. I don't think so, since each file seems to be followed by something like

debconf (filter): widget found for ubiquity/install/title
debconf (filter): --> 0 OK

but it's still crazy slow. The current file is taking more than 25 minutes. The only notable thing I can think of is that the Wifi is on and there are networks available. There isn't a hardware Wifi button. I guess I could've disabled it in the BIOS, but I've now progressed further than I did before, and I suspect it's working. Just excruciatingly slowly. I don't remember this happening when I installed 10.10 on my Eee.

Eventually, I think the screensaver kicked in, which led to an unresponsive blank black screen. I hard-rebooted again, but disabled the Wifi in the BIOS on the way. I went straight back to Ubuntu (i.e. I didn't reinstall via Wubi). The same sluggishness seems to be persisting, though: slow copying and long idle phases.

  • Is this a 64bit install or a 32bit install? I agree with you - an installation on your hardware shouldnt take more than 15 minutes. Can I suggest swap to 64bit if using 32bit and visa versa. – fossfreedom Sep 1 '11 at 9:25
  • It's 64-bit. After disabling the Wifi, it finished relatively quickly: it picked up at about the point it left off and suddenly skipped through to the end of a short wait. Probably 10-15 mins. I guess the issue is resolved, but the question remains... – Warrick Sep 1 '11 at 11:59
  • best to add your findings as an answer so that you can accept and close. However if you are looking for the answer to installing with wifi switched on - then add details of your wifi card into your question. I think it is still worth trying the 32bit wubi install. I have found weird stuff just like this with 64bit installs and visa versa. – fossfreedom Sep 1 '11 at 12:02

Following the advice in the comments, it seems that disabling the Wifi sped things up. I don't know if the system kept trying to connect to one of the networks instead of copying files or something.

Alternatively, if the Wifi wasn't what helped, then just keep trying. For me, the install finished on the third attempt.

  • I'm going to accept this because the Wifi does seem to be the problem. After a borked attempt at GNOME 3, I re-Wubi-ed from scratch with the Wifi disabled from the start. Re-installation took about 15 minutes from double-clicking Wubi to first boot into Ubuntu. – Warrick Sep 1 '11 at 14:02

For others stumbling on this page (like myself) that have the same Wubi installation problem (except that I'm using 32bit), see this series of postings in Ubuntuforums where this is answered in detail. Particularly, post #8.

Also, note that this didn't actually work for me. I finally installed the 11.10 wubi release which configures the install in windows without having to reboot to do the installation (I'm using Windows 7 on a Dell Inspiron E1505).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.