0

I have a personal Ubuntu Server that works just fine. I took an old work laptop (Dell Vostro) that used to have win7 installed. Since installing ubuntu, every 20 min or so while I am using Chrome, all the bars on my wifi signal disappear and the internet does not work. It was def not the router because everything else was working fine. At first I just rebooted and it came back. I figured it was a fluke thing until it continued. It doesn't have any issues if I am just using the laptop. But if I am using a browser, it keeps happening.

I tried to reset the drivers via the terminal.

$ sudo /etc/init.d/networking restart 
$ sudo service networking restart 
stop: Job failed while stopping  
start: Job is already running: networking

Neither cmd did anything.

I then tried unchecking Wifi Enabled via the GUI. When I re-checked it, wifi started working again. Since then, this has worked every time.

I am wondering if anyone has any ideas on what the problem is and if you know of a permanent fix.

I am currently trying to figure out exactly what checking and unchecking the WIFI does.

1
  • Welcome to Ask Ubuntu! ;-) Could you please go to a terminal by pressing [Ctrl][Alt][T] and type lspci&&lsusb. Then edit your question and copy-paste the output of the command into your question.
    – Fabby
    Mar 14, 2015 at 16:36

2 Answers 2

1

well, i dont know how amazingly this would work, but you could try:

ifconfig wlan0 down
ifconfig wlan0 up
sudo service network-manager restart

or even use wpa_supplicant, for which you can find a great guide here: Connect to WiFi network from command line in Linux - blackMORE Ops

0
0

If sudo service network-manager restart fixes the problem, you can make a script and run it through cron every 10 minutes or so.

3
  • Thanks but I have tried that and it def does not work. The only way I can get the wifi to work is by restarting the service via GUI or just rebooting the laptop. Mar 11, 2015 at 2:06
  • I have been trying to find out what exactly unchecking 'Enable Wifi'. I figured it was just the same thing as cmd "sudo service networking restart" or "sudo /etc/init.d/networking restart". IF that is the case, then just doing it via the terminal or a script, like you suggested, should work. But since it doesn't, I figured there must be more to it. Mar 11, 2015 at 2:09
  • @NicholasDeFazio: I think so too. That's why I added the comment below your answer... We need more info! ;-)
    – Fabby
    Mar 14, 2015 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .