0

On running Google Chrome, then a while later exiting all screens (using the top-right [X]) on each, I notice that the /opt/google/chrome/chrome process still persists, along with very many (20+) other sub-processes/threads.

On occasion, while these processes are still running and no Chrome windows are open, executing /usr/bin/google-chrome %U via a desktop launcher icon will:

  1. Open four Chrome windows in quick succession;
  2. Report the following error for each new window:

enter image description here

If I dismiss all the error messages, close all the Chrome windows, terminate all the Chrome processes, then run the same command again, everything works fine. It is only on occasion when the processes are already running does this occur.

It is unclear to me where to check/set permissions on the profile. Can anyone point me in the right direction to fix or avoid this problem?

UPDATE

  • This question suggests the problem lies in the syncing of passwords. I have tried disabling this, but the problem persists.
  • Yes, I have tried deleting the entire ~/.cache/google-chrome directory, and a purge/install of google-chrome, but the problem persists. Also, yes, I have made certain that the configuration option "Continue running background apps when Google Chrome is closed" is unchecked. My Chrome version is also 41.0.2272.89 (64-bit), and I've been experiencing this problem for several versions prior to this. – sharky Mar 11 '15 at 6:07
  • Whoops! Perhaps it was only .cache. I'll try deleting .config. Thanks. – sharky Mar 11 '15 at 10:26
  • I've now tried deleting ~/.config/google-chrome and ~/.cache/google-chrome, re-installing from scratch, and the problem persists. I am beginning to suspect there is a problem around the fact I am using the sync feature for everything: bookmarks, passwords, etc. – sharky Mar 12 '15 at 9:03
  • Good suggestions, thank you... I'll do both and edit the original question. – sharky Mar 12 '15 at 23:08
  • Please run find ~/.config/google-chrome ~/.cache/google-chrome ! \( -readable -writable \) -ls as regular user and post the result. This will uncover any files related to your Chrome profile, that aren't readable and writable by you. – David Foerster Apr 3 '15 at 17:28
1

This seems to be a bug in the current build 41.0.2272.x on Linux. What has worked for me is to rename/remove the "Web Data" file in your default profile. ~/.config/google-chrome/Default/ Unfortunately this is a temp fix as a new update will just revert the issue.

|improve this answer|||||
-3

I could fix it with using these commands

sudo chmod -R 777 ~/.cache/google-chrome ~/.config/google-chrome
|improve this answer|||||
  • 1
    -1 Making the Chrome configuration and chache files readable and writeable by everyone and flagging them as executable, doesn't sound like a good idea at all. – David Foerster Apr 3 '15 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.