0

Recently, after a software upgrade, the "Open Link" item in my xfce4-terminal right click menu stopped working: instead of opening the clicked URL in a new Firefox tab, it now opens a whole new Firefox window showing just the Firefox starting page.

How can I fix this so that I can open links from the terminal again?

1

This is caused by the removal of the -remote command-line switch in Firefox 36. If you have Mozilla Firefox selected as your preferred browser in the Preferred Applications settings, the terminal (or, rather, exo-open) is still trying to use that obsolete switch, which confuses Firefox.

See this bug report (bug #1429284) for more details.

In any case, there's a very simple work-around:

  1. Open the Preferred Applications setting (found under Settings in the Xfce menu, or by running exo-preferred-applications from the command line).

  2. Click the Web Browser selection menu, and select "Other..."

  3. Simply type firefox (or, equivalently, firefox "%s"), in all lower case, into the dialog that opens:

    Screenshot

  4. You should now have "firefox" (as opposed to "Mozilla Firefox") selected as your preferred browser. Now just close the Preferred Applications settings, and try opening a link from your terminal — it should work normally again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.