I know this question has been asked before and has been answered several times in askubuntu.

I have tried the advice (Creating or updating files as suggested) at the following links:

For example, on my system (HP G60, with Ubuntu Mate 14.04 64-bit install), I opened the file /etc/modprobe.d/wlan.conf in pluma, and it had 3 lines in which led_mode=1 existed.

Some of the other advice, mentioned MODULE NAME and that mine would be listed below. It didn't seem to list any for 14.04, how would I know what the module name is for Ubuntu Mate 14.04 specifically?

I realize this question may be difficult to answer without a dump from lspci, which I will do later this evening once I get home. I know only at this time it is Atheros.

Thanks in advance, Adam

[[appending info below, based on answer]] - I was able to determine module name as "ath5k"

$ modinfo ath5k

filename: /lib/modules/3.13.0-44-generic/kernel/drivers/net/wireless/ath/ath5k/ath5k.ko license: Dual BSD/GPL description: Support for 5xxx series of Atheros 802.11 wireless LAN cards.

... parm: no_hw_rfkill_switch:Ignore the GPIO RFKill switch state (bool)

the file /etc/modprobe.d/iwlwifi,conf already contained (as the last line in the file)

options iwlwifi led_mode=1

So, i'm not sure how to proceed at this point. Do I seek the electrical tape? LOL

Edit (March 12, 2015) Got the annoying blink to stop. Found at Wireless LED doesn't stop blinking on an HP dv5 with an Atheros AR5007

up vote 1 down vote accepted

The module name is found in:

sudo lshw -C network

Here is a redacted example from my computer:

*-network
       description: Wireless interface
       product: Centrino Advanced-N 6200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 35
       serial: xx:94:6b:99:55:xx
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.16.0-31

As you can see, the driver is iwlwifi, in this example.

Now, as to whether we can control the LED, we turn to: modinfo <your_driver>, in this example iwlwifi. We see, in part:

parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)

Therefor, if we wish to change the behavior of the LED, we would add to the already existing iwlwifi.conf file:

sudo -i
echo "options iwlwifi led_mode=3"  >>  /etc/modprobe.d/iwlwifi.conf
exit

In the case of many drivers, the behavior is not manipulable; in some cases, the driver parameter is found in one of the driver's dependencies. In my example, iwlwifi also loads iwldvm, cfg80211 and mac80211. I find this in:

lsmod | grep iwl

If I saw no method to change the LED behavior in iwlwifi, I'd check every dependency. In some cases, the only option is electrical tape.

Once you know your driver, if you get stuck, post back and I'll be happy to assist.

Again, in the case of many drivers, the behavior is not manipulable.

  • sorry but the steps you mentioned have not helped the blinking light annoyance. I'm looking for painters tape as it is less tacky than electrical tape – Adam T Mar 11 '15 at 10:42
  • I think I found something that worked. Even though the version stated is 11.10, the advice of first issuing some /sys/class commands, and (provided they worked) add them to a shell script - seemed to work!! My LED is solid blue instead of blinking!! askubuntu.com/questions/88103/… – Adam T Mar 13 '15 at 2:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.