0

I was running Kubuntu 14.04 LTS 64-bit on Acer Aspire 5560G for some months. I have updated regularly without any troubles.

Today I have decided to upgrade to 14.10. Upgrade worked flawlessly.

After restart I am not able to enter BIOS. It prints to press F2 to enter BIOS, but it does not react at all. No grub is displayed. No Kubuntu loaded.

It restarts and restarts. Every 5 seconds.

When I press F2 it just shortly beeps and restarts in two secods. When I put Kubuntu DVD it reads it for a while (20 seconds) and then restarts.

I have removed SSHD and the batery. I have tried to press any key combination I could think of. Nothing worked.

Any ideas would be very welcome.

As far as I remember I had previously UEFI/EFI booting troubles after upgrading Ubuntu/Kubuntu to 14.04. I was glad I got it booting. So actually I do not remember the current status of the Bios/UEFI/EFI configuration.

But anyway, BIOS should work. Could it even be corrupted by the installation process?

Thanx.

0

When you install an OS in EFI mode, it alters the NVRAM settings on the computer to point to the new OS's boot loader. Normally this works fine. My suspicion is that in your case, this change has affected the way the computer reacts to keypresses during startup or has otherwise affected startup options. If I'm right, this is a firmware bug. Some possible fixes spring to mind:

  • Use efibootmgr to view the current entries and remove any that aren't being used. I don't know of a good general efibootmgr tutorial on the Web, but if you do a Web search you'll find descriptions of how to use it to do various specific things. You can also read its man page. In brief, you'd use efibootmgr -v to view current boot entries and then use efibootmgr -b # -B to delete each one you don't want. (Replace # with the number corresponding to the entry you want to delete.)
  • Enter the firmware setup utility and review options related to "fast start" (disable it) or USB support (enable it). Of course, this poses a chicken-and-egg problem; you can't enter the firmware setup utility now, so you'd need at least a temporary workaround to get into the firmware once. This Acer page describes how to enter the firmware setup utility from Windows, but I'm not sure if it's generic or Acer-specific.
  • Configure GRUB to provide a reboot-to-EFI option, or install a boot loader that provides such an option. I'm not sure how to get GRUB to do this, although I thought I'd seen such options in GRUB somewhere along the line. My own rEFInd boot manager and gummiboot both provide this feature. (In the case of rEFInd, it appears as an icon of a computer chip on the second row of icons, and will not be present if the firmware doesn't provide the interfaces necessary for force a reboot into the firmware setup utility.) If you can get to the firmware's built-in boot manager, you could run rEFInd from a USB flash drive or CD-R to use this approach on a one-time or as-needed basis.
  • Update your firmware. This might reset things to a usable state, or it might fix the bug that's the real cause of the problem.
  • NVRAM - good point. I tried to google how to reset it. I tried ALT+F10, Shift+F10, Fn+Esc+power... so far no luck. I will try external USB keyboard, tomorrow. In case the keyboard settings are messed up. – milanBart Mar 10 '15 at 13:59
  • I have removed the CMOS battery over the night. Did not help. Even the external USB keyboard does not allow me to enter BIOS. I am totally stuck. Kubuntu 14.10 made my laptop crap. Do you know how to reset CMOS on this Aspire 5560? I have an service manual link but my board is different and I did not find any jumber to clear CMOS. – milanBart Mar 11 '15 at 8:30
  • My laptop's board differs to the one from the service manual and I could not locate any jumper to clear the CMOS. I had to took out the CMOS battery. But the CMOS was not cleared, anyway. Maybe some magical key combination would made the trick. Any ideas? – milanBart Mar 11 '15 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.