5

I have a wine package via a dependency from a package that gives you Silverlight and more up-to-date Adobe Flash for Linux. However, I get an error on startup of Software Center and also will repeatedly get an error icon in the top panel

enter image description here

with a message:

An error occurred, please run Package Manager from the right-click
menu or apt-get in a terminal to see what is wrong. The error message
was: 'Unknown Error: '<class 'KeyError'>'("The cache has no package
named 'wine-staging-i386'")'. This usually means that your installed
packages have unmet dependencies

I have gotten this to go away by doing something, I thought with Synatic, but right now Synaptic Package Manager->Edit->Fix Broken Packages is not fixing it. Selecting that tells me "Successfully fixed dependency problems" but I still have the error icon in the top bar.

Per comment below:

$ sudo apt-get -f install  
Reading package lists... 
Done Building dependency tree         
Reading state information... Done 0 upgraded,
0 newly installed, 0 to remove and 3 not upgraded.

$ sudo apt-get update 

Ign http://us.archive.ubuntu.com trusty
InRelease                               Ign http://ppa.launchpad.net
trusty InRelease                                   Ign
http://us.archive.ubuntu.com trusty-updates InRelease                 
Ign http://us.archive.ubuntu.com trusty-backports InRelease           
Ign http://ppa.launchpad.net trusty InRelease                         
Hit http://us.archive.ubuntu.com trusty Release.gpg                   
Get:1 http://us.archive.ubuntu.com trusty-updates Release.gpg [933 B] 
Ign http://ppa.launchpad.net trusty InRelease                         
Get:2 http://us.archive.ubuntu.com trusty-backports Release.gpg [933
B]         Hit http://ppa.launchpad.net trusty Release.gpg            
Hit http://us.archive.ubuntu.com trusty Release                       
Get:3 http://us.archive.ubuntu.com trusty-updates Release [62.0 kB]   
Hit http://ppa.launchpad.net trusty Release.gpg                       
Hit http://ppa.launchpad.net trusty Release.gpg                       
Hit http://ppa.launchpad.net trusty Release                           
Get:4 http://us.archive.ubuntu.com trusty-backports Release [62.0 kB] 
Hit http://ppa.launchpad.net trusty Release                           
Hit http://ppa.launchpad.net trusty Release                           
Hit http://us.archive.ubuntu.com trusty/main Sources                  
Hit http://ppa.launchpad.net trusty/main amd64 Packages               
Hit http://us.archive.ubuntu.com trusty/restricted Sources            
Hit http://us.archive.ubuntu.com trusty/universe Sources              
Hit http://ppa.launchpad.net trusty/main i386 Packages                
Hit http://us.archive.ubuntu.com trusty/multiverse Sources            
Hit http://ppa.launchpad.net trusty/main Translation-en               
Hit http://us.archive.ubuntu.com trusty/main amd64 Packages           
Hit http://us.archive.ubuntu.com trusty/restricted amd64 Packages     
Hit http://ppa.launchpad.net trusty/main amd64 Packages               
Hit http://us.archive.ubuntu.com trusty/universe amd64 Packages       
Hit http://ppa.launchpad.net trusty/main i386 Packages                
Hit http://us.archive.ubuntu.com trusty/multiverse amd64 Packages     
Hit http://ppa.launchpad.net trusty/main Translation-en               
Hit http://us.archive.ubuntu.com trusty/main i386 Packages            
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages      
Hit http://ppa.launchpad.net trusty/main amd64 Packages               
Hit http://ppa.launchpad.net trusty/main i386 Packages                
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages        
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages      
Hit http://ppa.launchpad.net trusty/main Translation-en               
Hit http://us.archive.ubuntu.com trusty/main Translation-en           
Ign http://dl.google.com stable InRelease                             
Get:5 http://dl.google.com stable Release.gpg [198 B]                 
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en     
Get:6 http://dl.google.com stable Release [1,347 B]                   
Get:7 http://dl.google.com stable/main amd64 Packages [1,182 B]       
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en     
Get:8 http://dl.google.com stable/main i386 Packages [1,181 B]        
Hit http://us.archive.ubuntu.com trusty/universe Translation-en       
Get:9 http://us.archive.ubuntu.com trusty-updates/main Sources [181
kB]         Ign http://dl.google.com stable/main Translation-en_US    
Ign http://dl.google.com stable/main Translation-en                   
Get:10 http://us.archive.ubuntu.com trusty-updates/restricted Sources
[2,564 B] Get:11 http://us.archive.ubuntu.com trusty-updates/universe
Sources [106 kB]    Get:12 http://us.archive.ubuntu.com
trusty-updates/multiverse Sources [4,463 B] Get:13
http://us.archive.ubuntu.com trusty-updates/main amd64 Packages [447
kB] Get:14 http://us.archive.ubuntu.com trusty-updates/restricted
amd64 Packages [9,238 B] Get:15 http://us.archive.ubuntu.com
trusty-updates/universe amd64 Packages [254 kB] Get:16
http://us.archive.ubuntu.com trusty-updates/multiverse amd64 Packages
[11.2 kB] Get:17 http://us.archive.ubuntu.com trusty-updates/main i386
Packages [437 kB]  Ign http://security.ubuntu.com trusty-security
InRelease                        Get:18 http://security.ubuntu.com
trusty-security Release.gpg [933 B]           Get:19
http://security.ubuntu.com trusty-security Release [62.0 kB]          
Get:20 http://us.archive.ubuntu.com trusty-updates/restricted i386
Packages [9,256 B] Get:21 http://us.archive.ubuntu.com
trusty-updates/universe i386 Packages [256 kB] Get:22
http://security.ubuntu.com trusty-security/main Sources [71.8 kB]     
Get:23 http://security.ubuntu.com trusty-security/restricted Sources
[2,061 B]  Get:24 http://security.ubuntu.com trusty-security/universe
Sources [17.9 kB]    Get:25 http://security.ubuntu.com
trusty-security/multiverse Sources [1,896 B]  Get:26
http://security.ubuntu.com trusty-security/main amd64 Packages [221
kB]  Get:27 http://us.archive.ubuntu.com trusty-updates/multiverse
i386 Packages [11.3 kB] Hit http://us.archive.ubuntu.com
trusty-updates/main Translation-en             Hit
http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en 
Hit http://us.archive.ubuntu.com trusty-updates/restricted
Translation-en       Get:28 http://security.ubuntu.com
trusty-security/restricted amd64 Packages [8,875 B] Hit
http://us.archive.ubuntu.com trusty-updates/universe Translation-en   
Get:29 http://us.archive.ubuntu.com trusty-backports/main Sources
[5,298 B]     Get:30 http://security.ubuntu.com
trusty-security/universe amd64 Packages [87.8 kB] Get:31
http://us.archive.ubuntu.com trusty-backports/restricted Sources [28
B]  Get:32 http://us.archive.ubuntu.com trusty-backports/universe
Sources [21.7 kB] Get:33 http://us.archive.ubuntu.com
trusty-backports/multiverse Sources [1,898 B] Get:34
http://us.archive.ubuntu.com trusty-backports/main amd64 Packages
[5,536 B] Get:35 http://us.archive.ubuntu.com
trusty-backports/restricted amd64 Packages [28 B] Get:36
http://us.archive.ubuntu.com trusty-backports/universe amd64 Packages
[25.4 kB] Get:37 http://us.archive.ubuntu.com
trusty-backports/multiverse amd64 Packages [1,245 B] Get:38
http://us.archive.ubuntu.com trusty-backports/main i386 Packages
[5,550 B] Get:39 http://security.ubuntu.com trusty-security/multiverse
amd64 Packages [3,458 B] Get:40 http://us.archive.ubuntu.com
trusty-backports/restricted i386 Packages [28 B] Hit
http://deb.opera.com stable InRelease                                 
Get:41 http://security.ubuntu.com trusty-security/main i386 Packages
[211 kB]   Hit http://deb.opera.com stable/non-free amd64 Packages    
Get:42 http://us.archive.ubuntu.com trusty-backports/universe i386
Packages [25.4 kB] Hit http://deb.opera.com stable/non-free i386
Packages                          Get:43 http://us.archive.ubuntu.com
trusty-backports/multiverse i386 Packages [1,249 B] Hit
http://us.archive.ubuntu.com trusty-backports/main Translation-en     
Hit http://us.archive.ubuntu.com trusty-backports/multiverse
Translation-en     Hit http://us.archive.ubuntu.com
trusty-backports/restricted Translation-en     Get:44
http://us.archive.ubuntu.com trusty-backports/universe Translation-en
[23.6 kB] Ign https://private-ppa.launchpad.net trusty InRelease      
Ign https://private-ppa.launchpad.net trusty InRelease                
Hit https://private-ppa.launchpad.net trusty Release.gpg              
Hit https://private-ppa.launchpad.net trusty Release.gpg              
Hit https://private-ppa.launchpad.net trusty Release                  
Hit https://private-ppa.launchpad.net trusty Release                  
Hit https://private-ppa.launchpad.net trusty/main amd64 Packages      
Ign http://deb.opera.com stable/non-free Translation-en_US            
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US        
Hit https://private-ppa.launchpad.net trusty/main i386 Packages       
Ign http://deb.opera.com stable/non-free Translation-en               
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US  
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US  
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US    
Hit https://private-ppa.launchpad.net trusty/main amd64 Packages      
Hit https://private-ppa.launchpad.net trusty/main i386 Packages       
Get:45 http://security.ubuntu.com trusty-security/restricted i386
Packages [8,846 B] Get:46 http://security.ubuntu.com
trusty-security/universe i386 Packages [87.8 kB] Get:47
http://security.ubuntu.com trusty-security/multiverse i386 Packages
[3,624 B] Hit http://security.ubuntu.com trusty-security/main
Translation-en              Hit http://security.ubuntu.com
trusty-security/multiverse Translation-en        Hit
http://security.ubuntu.com trusty-security/restricted Translation-en  
Ign http://extras.ubuntu.com trusty InRelease                         
Get:48 http://extras.ubuntu.com trusty Release.gpg [72 B]             
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Hit http://extras.ubuntu.com trusty Release                           
Hit http://extras.ubuntu.com trusty/main Sources                      
Ign https://private-ppa.launchpad.net trusty/main Translation-en_US   
Hit http://extras.ubuntu.com trusty/main amd64 Packages               
Ign https://private-ppa.launchpad.net trusty/main Translation-en      
Hit http://extras.ubuntu.com trusty/main i386 Packages                
Ign https://private-ppa.launchpad.net trusty/main Translation-en_US   
Ign https://private-ppa.launchpad.net trusty/main Translation-en      
Ign http://extras.ubuntu.com trusty/main Translation-en_US            
Ign http://extras.ubuntu.com trusty/main Translation-en               
Fetched 2,764 kB in 33s (82.6 kB/s)                                   
Reading package lists... Done


$ sudo apt-get -f install 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
  • Can you include output of sudo apt-get -f install? Sounds like you installed something weird from a PPA. And what do you mean by "wine package via a dependency from a package"? – Richard Mar 10 '15 at 3:39
  • @Richard I meant that I didn't install Wine, it came along with something else that I downloaded in order to be able to use Silverlight and/or a later version of Adobe Flash that works with DRM video. I think the package was Pipelight and it does have it's own repository: sudo add-apt-repository ppa:pipelight/stable – Scooter Mar 10 '15 at 3:59
  • Try a sudo apt-get update and then the previous command again? All we really know is that you installed something, and then the package manager is giving you that error. – Richard Mar 10 '15 at 4:02
  • dude, you fixed the problem. I don't see any errors. What exactly are you talking about? If you are referring to the "8 not upgraded" you need to run sudo apt-get upgrade or sudo apt-get dist-upgrade to upgrade (update) those 8 packages. – mchid Mar 10 '15 at 4:39
  • 4
    I may be reading this wrong and the problem may be that software center still won't open for you with the same error. if so, try running sudo apt-get install --reinstall wine-staging-i386 you see, running sudo apt-get update updates your cache and if you have added a ppa then you need to update the cache after adding the ppa or the packages will not be listed in your cache. – mchid Mar 10 '15 at 4:44
3

You can just "resolve" this by installing all pending updates. The message will go away. It is rather annoying, but there's not much you can do about it. For more information check this bug report: https://bugs.launchpad.net/pipelight/+bug/1318321

  • 2
    This solution have always worked for me. Just run sudo apt-get upgrade and the message goes away. – tigerjack89 Apr 20 '15 at 17:28
  • @tigerjack89..Hey thanks man..it worked for me too..:) – Rahul Singh Mar 24 '16 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.