1

I'm working on an Acer Aspire E 15 on which I installed Ubuntu Studio 14.04.

I have some issues regarding the audio.

In particular:

  1. The left speaker is not working at all. If I plug some external speakers, though, the sound works perfectly on both of them.

  2. If I mute the audio from this cascade menu: Cascade menu mute the audio actually gets muted. But if I mute it by using the keyboard option (Fn + F8), even though I receive this popup which informs me that the audio is now muted, actually the sounds keep on coming out of the speakers (wherever they are internal or external). mute popup

  3. I can't raise or lower the volume. However I do it from the previously seen cascade menu or by using the keyboard shortcuts the volume just stands still, at the maximum volume I suppose.

I tried to follow this guide I found on the italian Ubuntu website, even though it is not updated, and got some results through the terminal.

First of all, I think that the audio card has been correctly detected:

alex@Sargon:~$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xb3610000 irq 67
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xb3614000 irq 66
alex@Sargon:~$ lspci | grep -i audio 
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)

The audio test doesn't make any sound at all, though.

alex@Sargon:~$ aplay /usr/share/sounds/alsa/Front_Center.wav 
Riproduzione in corso WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Frequenza 48000 Hz, Mono

I tried to use Alsamixer to check the audio settings, but honestly I didn't understand anything in it. I also tried to reset it trough the commands I found in the previously linekd page, but those commands refer to Ubuntu 10.10, and don't work in Ubuntu Studio 14.04.

The most interisting thing is that according to that page another program might be occupying the Audio Card and, as a consequence, this might lead to issues. And apparently there may be several programs running: I wonder if this may be part of the problem.

alex@Sargon:~$ lsof | grep pcm
plugin-co 5106            alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
Chrome_Ch 5106 5107       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5132       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5133       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5134       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5135       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5190       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5191       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5192       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 5193       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
plugin-co 5106 6111       alex  mem       REG                8,7    27256    7080521 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so

I don't know how to proceed further.

EDIT:

After disabling automute the left speaker started to work. Yet the other issues remained. So I tried to terminate and restart the various audio processes through sudo killall pulseaudio and sudo alsa force-reload, after which the audio stopped to worked completely.

If I use the command this is what I get:

alex@Sargon:~$ sudo alsa force-reload
[sudo] password for alex: 
Terminating processes: 1871 (failed: processes still using sound devices: 6840(pulseaudio)).
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-realtek snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
Loading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

I wonder if those failed processes have something to do with the issue.

EDIT 2:

Working with Alsamixer I was able to solve the main problem: now the speakers work.

Still wondering about the other issues though.

  • i'm not positive but the left speaker sounds like it may be a hardware issue – mchid Mar 9 '15 at 22:37
  • I dual-booted Ubuntu Studio with Windows 8.1 on this machine. In Windows, the left speaker works. – il mietitore Mar 9 '15 at 22:38
  • one thing you can do is to run sudo killall pulseaudio then sudo alsa force-reload and see if that helps. Sometimes, sudo service pulseaudio stop; sudo alsa force-reload; sudo service pulseaudio start does the trick as well – mchid Mar 9 '15 at 22:41
  • I found the automute to be enabled on Alsamixer. Now the left speaker works. – il mietitore Mar 9 '15 at 22:45
  • I'll now proceed with those commands and see what happens. – il mietitore Mar 9 '15 at 22:46
1

To use alsamixer from a terminal, F3 gives you all controls, go left and right arrows to select each one. F6 to select soundcard although it looks like it's already selected.

One thing to note . . . make sure auto mute is not selected on the alsa mixer. Arrow up and down to control the volume.

After installing alsamixer this feature (automute) is set on by default and must be explicitly disabled.


edit:

Okay, thanks for posting the errors because they really help us know what's going on. The error says that pulseaudio is still using the modules which is why they fail to reload so we have to stop the puleaudio service. Here's what we'll do.

First, stop pulseaudio service with the following command:

sudo service pulseaudio stop

Next, reload alsa:

sudo alsa force-reload

Now, you NEED pulseaudio so start it back up:

sudo service pulseaudio start
  • Exactly what are these commands for? Working with alsamixer I was able to get the speakers back to work, so now the remaining issues are: - mute doesn't work if switched from the keyboard; - I can't adjust volume. – il mietitore Mar 12 '15 at 16:58
  • 1
    @ilmietitore alsamixer works independently from pulseaudio. The tray icon and your mute button switched from the keyboard control or interact with pulseaudio, not alsa, hence your problem. Pulseaudio controls alsa but alsa does not control pulseaudio. – mchid Mar 14 '15 at 19:56
  • 1
    @ilmietitore a better pulseaudio interface that can straighten things out is pavucontrol run sudo apt-get install pavucontrol and pavucontrol to run. – mchid Mar 14 '15 at 19:59
  • Thanks for the explaination. Yet, if I run sudo service pulseaudio stop what I get is stop: Unknown instance:. Pavucontrol is already installed; if I run pavucontrol I get the usual audio-management screen I get by clicking on the audio icon on the tray icon. – il mietitore Mar 18 '15 at 0:14
  • @ilmietitore it looks similar but it's not the same, although, it won't matter if pulseaudio isn't even running. – mchid Mar 22 '15 at 0:18
0

I was finally able to solve this one.

I just had to go in the configuration panel of the volume control box:

configuration panel

Under the "Audio Interno" (Internal Audio in english, I suppose) option, where now there is "Spento" (shut off) for some reason there was "Digital Stereo HDMI". I just jad to shut it off, and now everything works perfectly.

Thanks @mchid for all your help anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.