2

I've just bought a third monitor and additional the low-level graphics NVIDIA G210. (My onboard-card can only handle 2 monitors)

I set the "multi-monitoring" option in Bios and then tried the out-of-the-box solution with nouveau drivers. Ubuntu 14.10 managed it to make all displays work with correct resolutions. But the system was not really smooth anymore and the behavior was not as usual, so I installed NVIDIAs proprietary driver. The monitors in the graphics-card (HDMI + VGA) are working very well now, but the thrid monitor (onboard-graphic - DVI) - doesn't.

Name:~$ lspci -nnk | grep "VGA\|Display" -A2 

prints

00:02.0 Display controller [0380]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
    Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
    Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:8094]
    Kernel driver in use: nvidia

but xrandr --query shows

Screen 0: minimum 8 x 8, current 2820 x 1600, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 900x1600+1920+0 right (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900       60.0*+   60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x800       59.8  
   1280x720       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 298mm
   1920x1080      60.0*+   59.9     50.0     60.1     60.0     50.0  
   1680x1050      60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1280x800       59.8  
   1280x720       60.0     59.9     50.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   720x576        50.0     50.1  
   720x480        59.9     60.1  
   640x480        75.0     59.9     59.9  

How can I reconfigure the i915 driver and make the third monitor work again?

Thanks for help!

//edit

The configuration before: intel: HDMI nvidia: DVI, VGA As I said, all monitors were working with this configuration, but the system was not smooth.

The configuration I prefer: intel: HDMI,VGA nvidia: DVI After experimenting with xorg.conf, crashing my whole system, repairing it again, reconfigure all drivers, the DVI with nvidia worked, while both of the others showed the logo.

Now I tried Bumblebee with these results: The intel (hdmi+VGA) are working again. But the two monitors behave as one big, which is strange due to the fact that the VGA is in pivot mode. (I also have two cursors, when the cursor is at hdmi - one as usual - and one 90° inverted) Maybe someone knows a way how to fix this? 2nd problem: The nvidia is not working anymore. nvidia-settings are not able to detect the graphics card, although lspci -nnk | grep "VGA\|Display" -A2 shows

00:02.0 Display controller [0380]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
    Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
    Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:8094]
01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be3] (rev a1)

Why does the nvidia-driver does not appear here?

I also tried some configurations of bumblebee (add different nvidia drivers to /etc/bumblebee/bumblebee.conf Trying to make anything appear on the nvidia screen via optirun lets to

[ 2035.329815] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect. [
2035.329865] [ERROR]Could not connect to bumblebee daemon - is it running?

So, more and more problems are growing, but nevertheless bumblebee might be the correct way solving my issues!?

//edit 2: Another problem: The consoles [ctrl][alt][F1-F6] are not working anymore. Maybe the reason is the default output on nvidia vga, which cannot be displayed. But debbuging Xorg without these consoles is not cool.

  • Welcome to AskUbuntu! ;-) Did the DVI work before you added the NVidia? How was your set-up before? Are you running Bumblebee? – Fabby Mar 12 '15 at 22:55
  • Hi, thanks for your reply. I edited my configuration before and after. I've also edited the results of my first bumblebee-try. – Raphael H. Mar 14 '15 at 11:53
  • Dang! Remove Bumblebee and go back to the way is was. Sorry... – Fabby Mar 14 '15 at 14:10
  • 319??? Ouch! Does your BIOS support [hybrid] graphics? Can you follow these instructions to install the correct NVidia drivers first? Please back up your system before doing anything drastic like installing kernel modules! – Fabby Mar 14 '15 at 16:47
  • Install the 346.47 driver! See answer below! We'll take it from there... ;-) – Fabby Mar 14 '15 at 18:07
0

The standard Ubuntu NVidia drivers generate some problems on slightly older and slightly newer NVidia hardware.

If you want more then the standard Ubuntu repository drivers, install the xorg.edgers PPA. As the xorg.edgers group ask not to give installation instructions directly without linking to their page, this is the best I can do for now...

If you don't know what a PPA is or need some guidance about rolling forward and backward of driver versions after reading their page, leave a comment below.

After you've installed these drivers, set export DISPLAY=:0 and relaunch compiz + unity panel and the DVI will start working...

  • Oh, and for all my work, could you: 1/ just click the little grey under the "0" now turning it into beautiful green. 2/ Delete all your comments as I'm going to run into difficulties with the moderators as I should know better (I've already done the same with mine) – Fabby Mar 14 '15 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.