In my system, libpam-runtime/override is set to false (which I can see using debconf-get-selections).

Why when upgrading the system, specifically libpam-systemd, dpkg still pops up the window "Override local changes to /etc/pam.d/common-*?"? Should I preseed some other value? I can't find any.

The machine is an Ubuntu 14.04 server.

2 Answers 2


With Debian Jessie, explicitly setting the libpam-runtime/override value as follows avoided the interactive question during cloud-init:

  - 'echo "libpam-runtime libpam-runtime/override boolean false" | debconf-set-selections'
  - 'apt-get update'
  - 'apt-get -y install sssd-ldap'
  - 'systemctl enable sssd'
  - 'systemctl restart sssd'

Sounds like https://bugs.launchpad.net/ubuntu/+source/pam/+bug/682662:

It is by design of debconf that settings on the system take precedence over any values set in the debconf database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.