1

I installed 14.04 with Unity on my new box. Works pretty good. I installed Eclipse under Unity, but still haven't been able to create a launcher that displays the Eclipse icon. For other reasons I installed kubuntu-desktop and would now like to create a desktop launcher for the already installed Eclipse.

Initially I did a search in kickstart and drug the icon onto the desktop. This launches Eclipse with no trouble, but it has only the default gear icon.

So then I went to Dolphin and browsed to /usr/share/applications and drug out the .deskktop file I created there for Unity onto the KDE desktop. Now I have a desktop icon that has the proper Eclipse icon. But when I click it, Eclipse doesn't launch.

How can I get one icon on the KDE desktop with the proper Eclipse Luna icon (which is /usr/share/icons/eclipse.png -- I converted the icon.xpm file and put it there) that actually launches Eclipse?

Update --

Two things were needed. I had the permissions wrong on the .png file. It needed to be readable by everyone. Then the .desktop file needed to look like this:

[Desktop Entry]
Comment[en_US]=
Comment=
Exec=/home/tarka/eclipse/eclipse
GenericName[en_US]=
GenericName=
Icon=eclipse
MimeType=
Name[en_US]=eclipse
Name=eclipse
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DBUS-ServiceName=
X-DBUS-StartupType=
X-KDE-SubstituteUID=false
X-KDE-Username=

The key piece as in the comment was the line Icon=eclipse. Still don't know why it wouldn't work with the full path.

  • Added an answer, check it and if it works click the grey ☑ under the "0" at the left of this text, which means "I accept the answer" and also upvote! – Faizan Akram Dar Mar 9 '15 at 8:51
2

Open the shortcut with some text editor like gedit or kate icon by right-clicking on it, and selecting "Open with gedit". In the text editor, shortly after the 'comment' and 'app command' text, you should see something like 'Icon=exec,' (ignore the quotes) change it to Icon=/usr/share/icons/eclipse.png or Icon=eclipse

  • Thanks for the answer and congratulations: you fixed the Unity icon. I found the permissions for the .png file were for root only. Now Unity displays the icon normally. But the question was for KDE desktop. There is no edit option when right clicking in KDE, but I found the path to the .desktop file and changed the icon location. Now KDE shows no icon at all. It's just blank. – Brian.D.Myers Mar 10 '15 at 6:42
  • Right click on the shortcut (.desktop) file and edit it with kate or gedit then add following line to it Icon=/usr/share/icons/eclipse.png , if it doesnt work , write Icon=eclipse – Faizan Akram Dar Mar 10 '15 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.