2

This question already has an answer here:

When I update my system, I get the following errors:

Fetched 316 B in 22s (14 B/s)
Reading package lists... Done

W: GPG error: http://ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6AF0E1940624A220

Please someone suggest me a solution to this.

marked as duplicate by muru, Eric Carvalho, David Foerster, Fabby, Volker Siegel Mar 11 '15 at 11:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

You have to download the missing keys using this command in your case:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6AF0E1940624A220

For the CDRom errors check This thread

  • Given link solved it partially but, still I get the following error. W: GPG error: ppa.launchpad.net trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6AF0E1940624A220 – ss1729 Mar 9 '15 at 13:11
  • What output does this command give: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6AF0E1940624A220 Als try running apt-get update after running the previous command. – DriesSw Mar 10 '15 at 8:32
  • Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.dQhWdGIu31 --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 6AF0E1940624A220 gpg: requesting key 0624A220 from hkp server keyserver.ubuntu.com ?: keyserver.ubuntu.com: Host not found gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out gpg: no valid OpenPGP data found. gpg: Total number processed: 0 – ss1729 Mar 10 '15 at 13:15
  • It seems like your desktop can't reach the keyserver. Are you behind a firewall or proxy? If you are behind a firewall you can try running sudo apt-key adv --keyserver keyserver.ubuntu.com:80 --recv-keys 6AF0E1940624A220 If you are behind a proxy, you can use sudo apt-key adv --keyserver-options http-proxy=myProxy --keyserver keyserver.ubuntu.com --recv-keys 6AF0E1940624A220. Make sure you fill in myProxy. – DriesSw Mar 10 '15 at 13:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.