7

I am running Ubuntu 14.04 on think-pad T450. When using an external monitor with higher resolution than the in-built laptop screen, the text of dialog boxes are getting messed up.

Looks like I need to replace the Graphic card driver. Anyone found a solution to this?

Updated to add requested information:

lspci -nnk | grep '\[03' -A2

gives the following:

00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated
Graphics [8086:1616] (rev 09)
    Subsystem: Lenovo Device [17aa:5034]
Kernel driver in use: i915

Below is a screenshot, see how the letters are messed up on the screen.

Here's a screen shot showing the problem

  • Hello, welcome to askubuntu, could you paste the screenshot to your question? Also, please update it with lspci -nnk | grep '\[03' -A2 output from your terminal (Ctrl + Alt + t) – P.-H. Lin Mar 9 '15 at 8:46
  • Having identical problem on T450s on external 2550x1400 monitor. Exact same lspci output except [17aa:5036] on mine. Ubuntu 14.04.2 latest download and fresh install 3/24/15. – user184190 Mar 25 '15 at 21:50
8

Thanks all for your support. Luke put me on a track that solved the problem in a easy way. The issue relates to issues using SNA (Sandybridge's New Acceleration) with the Intel Graphics and need to revert back to UXA (Unified Acceleration Architecture). The way to do this is pretty simple:

Put the following:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

in file /etc/X11/xorg.conf.d/20-intel.conf, create the directory /etc/X11/xorg.conf.d/ if it does not exist. This must be done as root:

$ sudo mkdir /etc/X11/xorg.conf.d/
$ sudo cp  20-intel.conf /etc/X11/xorg.conf.d/20-intel.conf

Assuming you created the file 20-intel.conf in the local directory.

Hope that help others!

BTW, here's the source for the solution: https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues

0

It seems the problem was solved for me by removing Utopic HWE-Stack and downgrading X.org and Kernel to original Trusty version: How to remove Kernel/LTS Enablement Stack?

uname -r returns:

3.13.0-48-generic

and Xorg -version returns:

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-76-generic x86_64 Ubuntu
Current Operating System: Linux nibbler 3.13.0-48-generic #80-Ubuntu SMP Thu Mar 12 11:16:15 UTC 2015 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.13.0-48-generic  root=/dev/mapper/lvmgroup01-ubuntu ro splash quiet vt.handoff=7
Build Date: 12 February 2015  02:49:29PM
xorg-server 2:1.15.1-0ubuntu2.7 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
0

I was seeing similar, as well as a few more symptoms. It looks like this bug: https://bugs.launchpad.net/linux/+bug/1432194

  • 1
    Hi Like, while this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. Please take a look here: Why and how are some answers deleted? – bummi Apr 7 '15 at 9:46

protected by Community Apr 27 '15 at 16:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.