15

When I have a file browser and an image viewer opened and I double click a photo, the image viewer doesn't jump to the foreground, its icon just shakes a bit and acquires a glow around it, and I have to manually click on it to actually see the photo. How could I make it automatic, so that a double click on a photo shows it immediately, even when the image viewer is already opened in the background?

26

This behaviour can be changed from the command line, open a terminal and type:

dconf write /org/compiz/profiles/unity/plugins/core/focus-prevention-level 0

To restore the default value:

dconf write /org/compiz/profiles/unity/plugins/core/focus-prevention-level 1
  • hi, strange, in my ubuntu 14.04 there is no setting "focus-prevention-level" at this place :-| , any ideas ? – user157697 Sep 23 '15 at 12:53
  • @user157697, you should be able to find the setting via CCSM. See this answer. – wjandrea Oct 7 '15 at 1:44
  • 2
    Thank you so much for this. The default behavior was wildly irritating to me. – jdc Apr 22 '16 at 5:02
  • Worked for me on 14.04 – tigerjack89 May 15 '16 at 11:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.