0

I have an old AMD64 box that was working quite nicely on in 12.04 LTS with onboard Nvidia GeForce 6150SE nForce 430 chip but ONLY running Nvidia 302.7 which I learned the HARD way after trying just about every other driver. My son gave me an Nvidia GeForce 8800GTS card and my nightmare began.

To make a VERY long story short, the new to me graphics card ran just fine in the XP part of the dual-boot but Linux was Hell. Finally I gave up and "upgraded" to Ubuntu 14.04 LTS in an effort to fix the problem. I'm about sixty hours in and removed the 8800GTS card. I just want my system to work again. Nouveau graphics so slow they look like they are in another time zone. Move the mouse, go get a cup of coffee, and when I come back, I see the cursor move. I know that sudo sh NVIDIA-Linux-x86_64-302.07.run has fixed my graphics problems in the past. However, I get the error that [...]/version.h does not exist, most likely reason is that source files in /lib/modules/3.13.0-32-generic/build have not been configured. HOW do I get them configured?

Yes, I have updated, upgraded, installed linux linux-headers-generic ubuntu-minimal ubuntu-standard ubuntu-desktop and linux-generic all without having a version.h file appear. And yes, I wiped my drive and made a fresh install of 14.04 after removing the 8800 card because the gui was horribly broken.

Can anyone offer help getting my box to work with just the onboard graphics? I do not care about the 8800 card. I am pretty sure if I can JUST install nvidia 302.7 that my life will return to the halcyon days of 12.04, but in 14.04. Thank you.

  • 1
    You might need to run sudo apt-get install linux-generic for that version.h issue, reference here. – P.-H. Lin Mar 9 '15 at 2:21
  • If the particular drivers that you want to install are still not installable after you installed the header packages, then there is no way to install them. I remember when I had such setups, unfortunately this is a case of planned obsolescence, where Nvidia choose not to support certain products any longer with updated drivers, though the product is still fine. An honest recommendation is to get new hardware for the new OS. Current APUs from AMD or Intel ("HD" graphics) should be fine. New hardware will not be XP dual-boot friendly, use the old machine if you need XP, but you really shouldn't. – LiveWireBT Mar 9 '15 at 9:50
  • linux-generic was in my list. Yes, I suspect you are right, time for a new box. Either that or revert to 12.04 which worked. The only thing thing that nvidia_173 fails at is coming out of hibernate or suspend, the video tears so badly it is unreadable. Thanks for your input\ – Flash Mar 9 '15 at 15:52
  • If the above doesn't solve your problems, drop me a note @Fabby... ;-) – Fabby Mar 12 '15 at 20:09
1

Reinstalling Ubuntu 12.04.1 was the only solution to get a copy of version.h, but planting it in Ubuntu 14.04 did not help. Eventually I realized that within 14.04 I could load the oldest available driver in Ubuntu, Nvidia 173.14.39, with only one problem. Coming out of hibernate the entire screen is too distorted to read.

That can be fixed with unity --replace & which repaints the entire display screen.

So I edited ~/.bash_aliases to add an alias I called "fixit."

alias fixit 'unity --replace &'  

When you wake from hibernation and cannot read anything, hit Ctrl+Alt+T to open a terminal. Type fixit and hit Enter. You do not have to be able to read to do this. The screen blinks and everything is rewritten perfectly legibly. Then close the terminal window that you opened a moment ago.

Note: If I knew where to add the unity --replace command so that it runs every time the box wakes up from hibernation, I would put it there so that it works automatically.

| improve this answer | |
  • The latest update & upgrade apparently broke "unity --replace." Now, it performs the same as CTL ALT Backspace and destroys everything that was open before suspending. I had it working automatically by putting it in a file /usr/lib/pm-utils/sleep.d/99ZZZVideo. Now it is broken again. – Flash May 1 '15 at 23:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.