13

I have a little problem with my Ubuntu system.

When selecting boot on startup for a harddrive, the partition can't be mounted. The error which occurs is as follows:

dmesg | tail 
[  470.027891] EXT4-fs (sda2): Unrecognized mount option "x-gvfs-show" or missing value

The corresponding /etc/fstab entry is:

/dev/disk/by-uuid/d0e8607e-9067-49c9-929e-83ec7f70cea1 /mnt/d0e8607e-9067-49c9-929e-83ec7f70cea1 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Also in the GUI:

Unable to mount

Error while mounting

18

Short version:

You're not using the parameter as it was designed. Use comment=x-gvfs-show instead of x-gvfs-show...

Long version:

  • Don't use the GUI but edit your fstab manually by pressing Ctrl+Alt+T to go to a terminal and typing:

    sudo nano /etc/fstab
    
  • find the offending line that shows x-gvfs-show and type comment= in front of it

  • Ctrl+X
  • Save
  • Yes
  • reload all entries in fstab:

    mount -a
    

(Or if you just moved over from Windows: don't type mount -a and just reboot for old times' sake) ;-)

| improve this answer | |
  • I guess him didn't use the command, just copied from dmesg. It's a mistake of the mount commands of Nautilus or a fail with the drive. This message is shown, but we don't know where to chage it's value. – m3nda Aug 8 '15 at 11:45
  • @erm3nda: edited question to make it more beginner-friendly! ;-) – Fabby Aug 8 '15 at 20:34
  • 1
    Okey, fixed fstab with your suggestion. Someone didn't pay attention to that :) right? Thank you. – m3nda Aug 9 '15 at 12:40
  • Can this answer be improved with instructions on how to manually mount the drive without having to boot from a live cd or usb in order to edit /etc/fstab? – Simón Dec 29 '15 at 3:28
  • 1
    @Simón: Better now? (It only took me a year and 2 days to finally do as you requested) – Fabby Jan 1 '17 at 7:15
2

I thought I would add this here.

I recently switched one of my pc's from Ubuntu to Xubuntu (not with a clean install).

My external USB hard drives would no longer automount. Checking in gnome-disks they were set to automount but did not.

So I switched to manual mounting (which generates entries in /etc/fstab). The manual mount options were automatically populated with x-gvfs-show (no "comment="), which resulted in a failure to mount.

What I'm suggesting is that the fstab entries with x-gvfs-show may not have been manually generated.

| improve this answer | |
  • I can confirm this. I formatted and mounted a partition through the GUI and it added this option causing a failure to boot at mount. – Coljac May 15 '17 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.