I use following ubuntu version:

Description:    Ubuntu 14.04.2 LTS

I have been connecting to WIFI internet for last 5-6 months until the WIFI has stopped working a fine day. The WIFI connects to the wireless AP for the first time. But within 5 minutes this connection is lost. The system tries to connect back with no luck until I restart. This continues.

Please find the report generated using this script. Please help me how to resolve this problem.

echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Reboot The 11n_disable=8 enables agg tx and should increase your wifi speed and if you don't use sudo tee -a to append the iwlwifi.conf file you will delete what is already in there which is

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Try this in the terminal:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

The report you provided indicated that you are using Ubuntu 14.04.2 with kernel 3.13 which was the kernel from Ubuntu 14.04.1.

With 14.04.2 the kernel is version 3.16 which solved many WiFi issues including mine.

I am using the Atheros R9285 chip and I had the same issues of connection loses but not any more after upgrading to 14.04.2.

Please check for any available updates before trying the method above and check if the issue will be solved that way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.