0

I downloaded official ubuntu 12.04.5 LTS (64bit) ISO file and using my desktop Ubuntu (latest 14.10) and Startup Disk Creator I created bootable USB installation media. It all worked fine installing 12.04.5 on target system which is ACER TravelMate B115 set in UEFI Boot Mode and with Secure Boot Disable.

But my intension is to create my own pressed file for custom auto installation. In this forum I found question How to create UEFI-only bootable media. I followed instructions and I created UEFI bootable media. Very simple (copy all files from ISO image using 7z program as suggested directly to FAT32 formatted USB). At this point I have not changed any preseed file (or any other file from ISO image - stright copy). I plugged in USB key into ACER, rebooted it and I was able to select USB HDD boot from BIOS boot option menu. From GRUB menu I selected the 1st memu item - Intstall Ubuntu. So far so good. In usual installation dialogs I selected language, location, country keyboard, keyboard layout. Installation proceeded to detect hardware etc and then message is displayed in message box titled: [!!] Load installer component from CD

There was a problem reading form the CD-ROM. Please make sure it is in the drive. If retrying does not work you should check the integrity of your CD-ROM.

Failed to copy file from CD-ROM. Retry? 

I repeated USB disk creation and I had same failure. What am I doing wrong? Help!

  • The other reply on that question you quote had this trouble & used dd to create the USB. Tried that? – Mark Williams Mar 8 '15 at 8:49
  • Well, dd will create another identical ISO usb. What atractive to me in @LiveWireBT response is use of FAT32 USB and ease of changing preseed files to experiment with automatic installation. – Tadek Mar 8 '15 at 16:17
0

The error message reads to me like a certain file or package is missing or cannot be installed. The assumption of the installer that the medium is a CD is a bit confusing in this context of course.

In the syslog you sent to me the error message is:

cdrom-retriever: error: Unable to find 'pool/main/l/linux-lts-trusty/block-modules-3.13.0-32-generic-di_3.13.0-32.57~precise1_amd64.udeb'.

I just downloaded ubuntu-12.04.5-desktop-amd64.iso from http://releases.ubuntu.com/12.04.5/ but couldn't find this file after extraction with 7z. I don't think that there is data corruption on your USB drive, but please check with md5sum.txt.

I don't know why the installer tries to fetch this file from the local pool, when this file is not in md5sum.txt, where I guess it should be and it's unlikely that it's in casper. This confuses me, too. You can try downloading the package and copy it to the USB drive manually. May be that is the only issue and everything will be fine after that.

Alternatively you could use the loopback method I just added to my answer (it was long overdue). You would need to modify the ISO or find other ways to include your preseed file, but wouldn't run into filesystem issues or other things that I currently don't know about.

  • LiveWireBt, Thank you for thorough analysis of the problem I have. I thought it must be something wrong with the contents of downloaded ISO image. But: (1) I checked checksums and it was correct; (2) I used same image with StartupDiskCreator and it worked. i.e. It installed Ubuntu 12.04.5 LTS (AMD64). – Tadek Mar 9 '15 at 18:54
  • 24h after-> I am using ubuntu-12.04.5-alternate-amd64.iso and .../vlock-modules-3.13.0-32-generic-di_3.13.0-32.57~precise1_amd64.udeb file is present and has correct checksum:-( Then I tried your new The ISO loopback method (advanced) in UEFI-only bootable USB. Unfortunately it does not work with 12.04 and if I use 14.04 there is no text based installation and installation questions and answers different making my task of revamping legacy code even harder. Any suggestions? – Tadek Mar 10 '15 at 20:07
  • @Tadek: that one is a new question – Fabby Mar 12 '15 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.