I have an Asus N56JK computer and I have tried many different options such as updating the Grub file in /etc/default/grub but to no avail. All other Function keys seems to be working but only function keys used to adjust brightness are not working?

  • This should not have anything to do with Ubuntu. This should be specific to your laptop. Therefore, a manual specifically for your Asus N56JK should be the best approach. Still it would be interesting to know, have you already tested the Fn keys within Windows? – Socrates Mar 8 '15 at 3:51
  • Yes it works as it should on Windows, only Ubuntu where it does not. – user1287412 Mar 8 '15 at 4:19
  • Try the Brightness-settings within System Settings. It's the symbol with the black monitor and a lock within the screen. You can set the brightness there manually. – Socrates Mar 8 '15 at 4:54
  • You may as well check the Keyboard within the System Settings. Within that window you have two tabs. The right one leads you to the Hotkey settings. – Socrates Mar 8 '15 at 4:55

I have a Asus X551MA, here is what worked for me.

Update Grub;

  1. Open terminal with Ctrl+Alt+T

  2. type in terminal;
    gksudo gedit /etc/default/grub

  3. Change;
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_osi="

  4. Save and Exit gedit

  5. type in terminal;
    sudo update-grub

  6. Restart your computer; (Don't forget to bookmark this page)
    sudo shutdown -r now
    This should fix your issue, if not keep reading.

Create 20-intel.conf; Intel GFX card only!

  1. Open terminal with Ctrl+Alt+T

  2. type in terminal;
    cd /usr/share/X11/xorg.conf.d

  3. now;
    sudo touch 20-intel.conf

  4. then type;
    gksudo gedit 20-intel.conf

  5. Copy & Paste the following lines into the document;

    Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"
    EndSection
    
  6. Save and Exit the document.

  7. Restart your computer;
    sudo shutdown -r now
    This should work, if not keep reading.

Install 3.16 kernel for 14.04 LTS;

  1. Update;
    sudo apt-get update

  2. Install;
    sudo apt-get install linux-image-generic-lts-utopic

That's all I got, sorry if this is incompatible with your set-up as there may be additional steps required, and I prefer to refrain from giving blind advice. I do recommend upgrading the kernel however, as this may be the solution you need, if you are using Ubuntu 14.10 or later there is no need to upgrade the kernel.

  • I have the ASUS UX305CA (Intel m3, Skylake graphics) and confirm this worked perfectly. – jonnybazookatone Oct 10 '16 at 4:22
  • Asus X550LN, Debian 8.6 @ linux3.16 - worked already after updating GRUB. Mighty thanks! – Artalus Jan 5 '17 at 22:02

I have an ASUS UX305FA zenbook and the above suggestions re: messing around with /etc/default/grub ddidn't work for me.

This worked for me: https://github.com/thezerobit/asus-zenbook-ux305fa

Install xbacklight

sudo apt-get install xbacklight

In Keyboard settings, set up custom shortcuts to increase or decrease backlight by calling xbacklight -inc 10 or xbacklight -dec 10.

Edit: I own this laptop too and the xbacklight workaround does work. you should just not use the fn + f5/f6 buttons but use other keys, mine are ctrl + f3/f4. Also if i decrease too much, the screen will go entirely black..

  • I've set the shortcut keys to just F5 and F6, which is similar to how a macbook operates and so far I haven't had any problems :) – Brad Smith Jul 23 '15 at 1:50
  • 1
    Tried on UX305CA, didn't work for me =[ – jonnybazookatone Oct 10 '16 at 4:23
  • On June 2017 it worked great for my ASUS UX360C – Rodrigo Jun 4 '17 at 16:17

protected by Community Jan 17 '17 at 2:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.