0

I'm trying use my internet and I've been connected with a cord for a month now. I've been looking everywhere to find the answer to my problem, but they won't work. I have a realtek wireless router. When I try to use my wireless, it goes to crap. It is very very slow. When I try to use my wireless, it fluctuates from not working, to a really slow internet speed. My phone, and my other computer works fine, and the other one has windows. So it has to be a Linux problem. I'm running on Ubuntu 14.04,Co

Results of lspci -nnk | grep -iA2 net

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 07) 
    Subsystem: Hewlett-Packard Company Device [103c:2190] 
    Kernel driver in use: r8169 
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
    Subsystem: Hewlett-Packard Company Device [103c:197d]
    Kernel driver in use: rtl8188ee
  • Do you know what kind of WiFi adapter your computer is using? If you have a laptop, there might be info about your WiFi adapter on the bottom. If your adapter is USB, it might say somewhere on the USB device itself. – TSJNachos117 Mar 7 '15 at 10:12
  • Add the results of lspci -nnk | grep -iA2 net to your question – Jeremy31 Mar 7 '15 at 12:10
  • 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 07) Subsystem: Hewlett-Packard Company Device [103c:2190] Kernel driver in use: r8169 03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01) Subsystem: Hewlett-Packard Company Device [103c:197d] Kernel driver in use: rtl8188ee – Elijah Shackelford Mar 7 '15 at 23:42
0

There are a couple fixes, option 1 is echo "options rtl8188ee ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8188ee.conf and reboot, if no improvement we can install backports

sudo apt-get install linux-headers-generic build-essential
wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.19-rc1/backports-3.19-rc1-1.tar.gz
tar -zxvf backports-3.19-rc1-1.tar.gz
cd backports-3.19-rc1-1
make defconfig-rtlwifi
make
sudo make install

Reboot

If you install updates and notice the same issue with wifi, it is likely caused by a kernel update, then you need to

cd backports
make clean
make defconfig-rtlwifi
make
sudo make install

Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.