1

I installed 7 operating systems in my PC. All worked very well. (Ubuntu 11, Ubuntu 14, EduBoss, Redhat6, Nodezero, Windows 8, Win 7). I frequently used Windows 8 and Ubuntu 14 last 6-7 months, I enjoy all operating system but one day after CHKDSK perform by Win7 my PC was unable to start with windows boot. If I try to start windows PC restarts very fast and shows nothing to any options just restart.

All other Linux O.S. work but no any other Win boot is working. As per my knowledge I guesses that problem occurred by file corruption or by CHKDSK operation by Windows.

Can I repair Windows boot option by Linux? (without win bootable disk)

  • Architect i386
  • 2 Gb ram
  • Intel quad core
  • OS. First I installed windows and then Linux.

3 Answers 3

3

One of the methods using Linux is to use fsck.msdos command which is found majorly in most of the Linux Distributions. While you've not mentioned that is there any error shown by Windows and, it is not mentioned too whether it is possible to boot into Safe Mode by pressing and holding Shift and tapping F8 repeatedly. Based on the dearth of information here, I advise booting into Linux, open the Terminal, and type:

  • sudo fsck.msdos /dev/XYZ where XYZ is the partition where Windows is installed(say sda1).

There are many parameters available which can be accessed by typing fsck.msdos -h but the basic command should be able to correct your Windows.

If that went well, you will want to check whether Linux is able to detect Windows loader now or not. Besides, you need to generate a new GRUB configuration file too. I'm assuming the Linux you're booted into is running Grub 2.0. To Probe the Boot Loader, type the command:

  • sudo os-probe, it shall give you an output like this:

/dev/sda1:Windows 7 (loader):Windows:chain

If you receive any such output, you can go ahead for building new Grub configuration file. In Terminal, type:

  • sudo grub-mkconfig -o /boot/grub/grub.cfg, if your grub.cfg is at some other location then replace the path in the command with your file location.
  • Type sudo grub-install /dev/sda where sda is my primary HDD having Windows and Linux installed.

Reboot, and choose Windows in Grub Menu. it should boot. If it doesn't we can try other methods but your question demands only Linux-specific solution.

7
  • madhavnikam@madhavnikam-Aspire-E5-511:~$ sudo fsck.msdos /dev/sda2 fsck.fat 3.0.26 (2014-03-07) Currently, only 1 or 2 FATs are supported, not 0. Commented Mar 7, 2015 at 18:18
  • sudo grub-mkconfig -o /boot/grub/grub.cfg Generating grub configuration file Found linux image: /boot/vmlinuz-3.13.0-46-generic Found initrd image:/boot/initrd.img-3.13.0-46-generic Found linux image:/boot/vmlinuz-3.13.0-24-generic Found initrd image:/boot/initrd.img-3.13.0-24-generic Found memtest86+image:/boot/memtest86+.elf Found memtest86+image:/boot/memtest86+.bin Found Windows8(loader)on /dev/sda1 Found Debian GNU/Linux(7.0)on /dev/sda10 Found RedHatEnterpriseLinuxServerrelease6.4(Santiago) on /dev/sda12 Found Ubuntu11.04(11.04)on /dev/sda14 Found Ubuntu10.04.1LTS(10.04)on /dev/sda8 done Commented Mar 7, 2015 at 18:27
  • madhavnikam@madhavnikam-Aspire-E5-511:~$ sudo grub-install /dev/sda6 Installing for i386-pc platform. grub-install: warning: File system `ntfs' doesn't support embedding. grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.. grub-install: error: will not proceed with blocklists. Commented Mar 7, 2015 at 18:30
  • windows boot problem not solve nothing do any new. PC still restart when try to run windows boot loader. But it upgrade GRUB loader with sequence of disk-part. any other solution for it? Commented Mar 7, 2015 at 18:43
  • any other idea to solve that? can i repair by using Windows disc ? if by windows disc: can it affect GRUB >? YES then how to recover GRUB? I fail to solve that problem without windows disk. I think it is nearly impossible to solve that problem without windows disk. PLZ tell any other method to solve that..... Commented Mar 8, 2015 at 10:19
1

Have you try Boot-Repair tool? It seems that your boot files were messed up by CHKDSK.

1
  • i solve this problem by using win disk(both answers are very helpful).thanks problem solved. Commented Mar 27, 2015 at 18:30
0

1> use win7 disk
2> start up repair
3> chkdsk >>>> restart
after restart win boot louder start but GRUB not.
to fix that USE "BOOT-repair" disk and "fsck.msdos" commands.
both answers are very helpful together.

3
  • friends my answers is depends upon previous two answers. Commented May 22, 2015 at 18:39
  • above both answers are very useful. Commented May 22, 2015 at 18:40
  • But it is nearly impossible that you can FIX windows boot problem without windows Boot CD. Commented May 22, 2015 at 18:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .