2

Have been trying to install Gnuradio for several days and keep having trouble with qt4 not building/installing properly. Seemed to depend on a thing named 'unity-control-center' which claimed to be dependent on two libraries, both of which claimed to be up to date. This is what I got if I tried to install just qt4. Get exactly the same unmet dependencies if I try to install any qt4 app from the Software Center, FWIW.

ftoewe@ftoewe-Inspiron:~$ sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
ftoewe@ftoewe-Inspiron:~$

Asked for help a couple of days ago and got messed up trying to complete a suggestion. So back trying again. Thanks in advance.

1
  • 1
    This did help. Was able to install qt4 after doing as suggested in the referenced post. Plan to start over wit a fresh install as have made so many failed attempts, have probably hosed the OS terribly. Many thanks to David Foerster.
    – FredT
    Mar 7 '15 at 11:32
2

The solution suggested in this posting worked "Can't install libglew-dev because libcheese and libclutter don't have the required versions". Was able to install qt4 after doing as suggested. Many thanks to Harris and David Foerster.

I tried to install libglew-dev and I had the same problem. I had to include the following packages to install it

sudo apt-get install libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0

It will include then all the required packages.

Not the answer you're looking for? Browse other questions tagged or ask your own question.