1

I hope this won't be marked as a duplicate as I've tried almost all answers to similar questions I could find on this site. My Sony Vaio runs Windows 8.1 and I wish to dual boot Ubuntu 14.10 on it.

Here's how I installed Ubuntu:

  • Disable secure boot and fast startup.

  • Boot from USB and install.

  • I selected 'install beside windows 8.1' and did not select 'something else'

After the installation the laptop rebooted, since my USB was still plugged in, it booted into it and realized I made a mistake. I powered off the laptop, pulled the USB stick out and then turned it on. It booted straight to Windows 8.1.

My boot order was CD > External > Internal. Network boot is disabled.

Here are some of the things I tried after looking at similar questions on this site:

  • I tried the following commands bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi , bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi, with secure boot enabled and disabled accordingly but still no sight of grub.

  • I then shift clicked restart > selected use a device in the menu that came afterwards > and selected ubuntu from there and the laptop rebooted. But unlike the other questions I've seen on this site, once again Ubuntu did not load and instead windows booted up. This method works for this individual.

  • Afterwards I tried the boot-repair after booting into the live CD but that did not work either. Here is the file that was generated from the boot-repair tool :(http://paste.ubuntu.com/10551408/).

A very similar question that I don't understand the solution to:

This question on AskUbuntu seems similar to mine except he manages to get the grub menu showing using his little hack, but that does not work for me (mine boots right into Windows).

Also, I do not understand how to carry out the most voted answer to that question.

More details about my laptop:

It's a Sony Vaio E14P: SVE14A290X with a 240 gig Intel SSD, added by myself. I noted that other Sony laptops (different models) had issues with SSD's but all of them managed to load the grub menu without a problem.

EDIT:

Something else I found when following this tutorial:

To set GRUB2 as the default bootloader follow these steps:

Login to Windows 8
Go to the desktop
Right click on the start button and choose administrator command prompt
Type mountvol g: /s (This maps your EFI folder structure to the G drive). 
Type cd g:\EFI
When you do a directory listing you will see a folder for Ubuntu. Type dir.
There should be options for grubx64.efi and shimx64.efi
Run the following command to set grubx64.efi as the bootloader:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Reboot your computer
You should now have a GRUB menu appear with options for Ubuntu and Windows.
If your computer still boots straight to Windows repeat steps 1 through 7 again but this time type:

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

Reboot your computer

When I type dir, to check the directory contents, instead of a folder called Ubuntu I get a huge list of windows related files. Does this mean my ubuntu is not installed in the correct place?

FINAL UPDATE:

After trying so hard for so many days, running codes and messing with things I didn't know, I tried installing EasyBCD (something I missed out on somehow) and using that I deleted the Sony boot loader entry, the Windows 8.1 boot loader entry and just left Windows 8.1 and ubuntu and rebooted, and guess what? Grub loaded up!! Windows works fine too. I followed this tutorial. Thanks everyone who tried to help me! I really wish it hadn't been this daunting but oh well!

  • Tried to shrink your HDD (SSD) in Win8 and then chose "something else" when installing? Then see where the bootloader is installed? – aXept Mar 7 '15 at 15:22
  • Do you recommend installing the bootloader in a separate partition or not installing it at all. I read in places that the windows bootloader can add Ubuntu as an entry and boot it if grub is not installed. Is this true? – john Mar 7 '15 at 16:34
  • Well, I installed the bootloader like the installation wanted, didnt change it. (dev/sda). Maybe you could try not to choose install beside windows but "something else" and make your own partitions for it (Ubuntu). I did shrink my HDD in win8 first, then made partitions for Ubuntu in the installer. – aXept Mar 7 '15 at 17:54
1

Try use the recommended Boot Repair from a Ubuntu Live CD/DVD/USB

Run these commands in a terminal in number order with a internet connection:

  1. sudo add-apt-repository ppa:yannubuntu/boot-repair
  2. sudo apt-get update
  3. sudo apt-get install -y boot-repair && boot-repair

Press the enter/return key after typing each command

Answer source.

  • I already tried this. Here is the log I got. paste.ubuntu.com/10551408 – john Mar 6 '15 at 21:30
  • You show two Windows UEFI entries, one for grub and one for Windows? Can you choose either in UEFI menu or one time boot key? Most copy grub or shim into /EFI/Boot and rename grub to bootx64.efi. Then boot hard drive entry in UEFI. askubuntu.com/questions/486752/… – oldfred Mar 6 '15 at 23:08
  • GParted says boot is in dev/sda3 but that partition does not show up in the Files app. How can I access it to try the file renaming method? – john Mar 7 '15 at 9:00
  • @oldfred I copied that file to EFI/Boot and renamed it but no change at all, Windows continues to load with no sign of grub. – john Mar 7 '15 at 16:31
1

Sony seems to do some strange things with their EFI installations. I've seen many problem reports similar to yours, but I don't own a Sony, so I'm unable to experiment hands-on and figure out the best workaround. If this is a new computer, I'd seriously consider returning it because of these problems. If you do, write a letter to Sony telling them why you returned the machine. Companies are like dogs; they'll deliver an unpleasant brown substance unless they're swatted on the nose when they do! For a company, a "swat on the nose" is accomplished by returning a product.

If you decide to keep the computer, try using a rEFInd USB flash drive or CD-R to boot. If you can get rEFInd to boot, it should give you options to boot either Windows or Ubuntu. This will at least enable you to get into a more comfortable Ubuntu environment than the emergency disk you're presumably using to run Boot Repair. You can then read up on how EFI loaders work, experiment with efibootmgr and renaming various files, and maybe find a solution.

Another option is to completely delete everything on the computer and re-install it from scratch. I've heard that Microsoft has recently made legal Windows 8 installation media available for download. Re-installing Windows using a stock disk set will have the advantage that you won't have OEM-specific bloatware or OEM-provided security compromises like Superfish. Such a setup, being "plain-vanilla" rather than "super-duper ehanced with weird stuff," should be easier to manage. Note that for this to do any good, you'd need a stock Microsoft installer, not something provided by Sony.

  • Thanks for your answer. Ultimately, I'm dawning on the same conclusion that if this is ever to work, I'll have to replace windows completely. As much as I'm annoyed with Sony for this, I still appreciate how this machine has run Windows almost flawlessly for the last 2 years. Lastly, if I install Ubuntu with the option 'erase everything and install', do you think it will let Grub load without a problem? I just dont want to take the plunge and be stuck without a proper working OS (I'm gonna be backing up Windows ofcourse but still..). – john Mar 7 '15 at 16:29
  • Update: I managed to fix my problem using EasyBCD! See the last update for more info. Thanks. – john Mar 7 '15 at 18:28
-2

I had a very similar issue and had it resolved last night. Try this and see if it works.

If you don't see any boot leader and Ubuntu starts directly then you have to edit your grub file. Follow these steps. Press Crtl+Alt+T to open Terminal or search Terminal from dash.

Then enter following command:

sudo gedit /etc/default/grub 

Change values as below wherever necessary:

GRUB_HIDDEN_TIMEOUT=0

GRUB_HIDDEN_TIMEOUT_QUIET=false 

GRUB_TIMEOUT=10

Then save the file (Crtl+S) and run following command in terminal.

  sudo update-grub

Reboot your system

  • Just to be sure: I'm always booting to Windows 8.1 and can only ever access Ubuntu through the live CD method. Are you saying I should try this with the live CD? – john Mar 6 '15 at 20:17
  • this guy says that he cannot access ubuntu. without accessing ubuntu how can he try this solution? – Edward Torvalds Mar 6 '15 at 20:31
  • Yes because it sounnds like an issue with Grub. And from my knowledge there's no way to fix this via windows. If you have a live CD or USB, boot off that and try this. – Alkarin Mar 6 '15 at 20:32
  • This gives me some access error when I try to run the last command. sudo update-grub – john Mar 6 '15 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.