Due to some issues I've had with VirtualBox, I recently switched to using Qemu, with the Qemulator GUI, and all has been well when playing with Linux virtual machines.

However, due to needs from my very-Microsoft-married school, I need to install Windows 7, but I'm having a problem. The Win7 installer is only seeing the virtual drive as 1GB in size and refuses to install on it. I initially used the "Auto" setting when creating the drive, but when that didn't work, I tried setting it explicitly to "Qcow2" after finding an old tutorial. That didn't work, either.

Is there a particular drive type that reports its size to Windows correctly? Or, is there a way I can tell Qemu to tell the VM that the size is different from its starting size (since the default is a dynamically expanding format)? The VM drives are stored on a 1TB drive with 3/4 of its space unused, so I'm not really concerned about drive space and a static-sized file could be used, if that's what it takes.


I don't know about your problem, but I successfully installed Win7 on qemu with this command:

virt-install --connect qemu:///system -n win7 -r 2048 --vcpus=2 -f win7.qcow2 -s 30 -c win7.iso --vnc --noautoconsole --os-type windows --os-variant win7 --accelerate --network=bridge:br0 --hvm

-n Name
-r Ram
-s Size in GB
-c Installation media

You might want to try this

  • Thanks, I'll give that a try when I get some time and get back to you. :) – Shauna Aug 31 '11 at 18:06
  • For anyone else who has this problem, I had to adjust it to: virt-install -n win7 -r 2048 --vcpus=2 -f win7.qcow2 -s 30 -c win7.iso --vnc --os-type windows --os-variant win7 --accelerate --network=user --hvm and install both virt-install and virt-viewer (separately, for whatever reason virt-viewer doesn't install with virt-install) to get it to work, but it recognizes the size of the drive and is so far installing with no problem! – Shauna Sep 5 '11 at 12:57
  • this doesn't work for me. It launches the installer, but windows installer then says that a device driver is missing. It cannot see the disks. I've tried libvirt and raw and qcow2 disks. I'm stuck :( I'm on Ubuntu 11.10. – Jay _silly_evarlast_ Wren Jan 11 '12 at 21:04

First you have to create an image to use like a hdd:

qemu-img create -o size=30GB win7.img

Then start the qemu to use the ISO as cdrom:

qemu-system-x86_64 -cdrom path/to/win7.iso -hda win7.img

It will install windows, then, to start it:

qemu-system-x86_64 -hda win7.img

I hope this will help you,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.