How do I configure Ubuntu to input Chinese?

  • I'm using Ubuntu 15.10, I use aptitude install the package ubuntu-keyboard-chinese-pinyin to get the pinyin imput method to be worked.
    – Shawn Xie
    Nov 5, 2015 at 8:54

8 Answers 8


My system had a similar problem: I was able to choose "Chinese", but it didn't really input any Chinese. The key step missing was to install a specific Chinese input method/package. E.g.:

sudo apt-get install ibus-pinyin 

After installing Pinyin in this example, go to System SettingsLanguage SupportChinese (Pinyin).

Now it works as expected.

This thread helped me to figure out this solution. It also suggests another input method:

sudo apt-get install ibus-sunpinyin


After either of those commands do not forget to restart the IBus daemon

ibus restart
  • It helped me, however (as I could imagine) Nautilus is triggering errors all the time when Pinyin is selected. Mar 2, 2019 at 13:08
  • 2
    Update: on newer Ubuntu (e.g., 18.04 and later), Pinyin could be installed through GUI without touching command lines, following these steps.
    – Samuel Li
    Mar 2, 2019 at 21:16
  • @SamuelLi , thank you so much! Your link works wonders !
    – evaristegd
    Mar 20, 2020 at 22:48
  • 1
    ibus-sunpinyin is better than ibus-pinyin, ibus-pinyin can't be used in intellij
    – Jess Chen
    Sep 12, 2020 at 2:19
  • It helped me every time I reinstalled Ubuntu Apr 21, 2022 at 4:28
  1. click dash home, search for "language support"

  2. click "install/remove language" and add Chinese

  3. click dash home, search for "keyboard input method"

  4. under "input method",add Chinese input method

  5. enjoy!

hopefully it helps

  • is this available through apt-get? Apr 12, 2014 at 14:11
  • 1
    Ubuntu 16.10 only finds Text Entry when searching for keyboard input method, and there does not seem to be any way to add "input methods" in that dialog box. Dec 23, 2016 at 23:03
  • 2
    Didn't work for me. (in 16.04) I installed Chinese, and clicked a checkbox that allowed me to see the icon in the menu bar that shows which language is active. There is an item under there that says "Text entry settings." I added three chinese language items. I activated them all one at a time, but no Chinese is ever produced in any textbox I've tried.
    – rschwieb
    Feb 8, 2017 at 16:01
  • This doesn't work on Ubuntu 20.04. I installed the language under "Language Support." However, in "Region & Language," when I click the + button under "input Sources," the only options listed are english ones.
    – Caleb Jay
    Jul 7, 2021 at 6:08
  • This does not work 2023. You can add the Chinese input but it doesn't actually popup pinyin or any other input method. It seems to do nothing. Oct 7 at 23:01

setup instructions for chinese character support in (ubuntu 14.04) and (ubuntu 16.04)

  1. Enable Chinese Language Support

a - Click System Settings, Click Language Support

you may be prompted to install support for current languages

b - Ensure that Keyboard input method system: is set to IBus

c - Click Install / Remove Languages..

d - Choose Chinese (simplified) and/or Chinese (traditional)

e - (ubuntu 14.04) - Click Apply Changes

e - (ubuntu 16.04, 18.04, 20.04) - Click Apply

Logout Login<

  1. Install Additional Chinese Input Systems

this step will not work for 16.04 as ibus-m17n can no longer be found through software center

a - Open Ubuntu Software Center

b - Search for and install ibus-m17n

Logout Login<

  1. Select And Enable Your Input Systems

a - Click System Settings, Click Text Entry

b - Click the + button to add new methods

c - Select Chinese (Pinyin), click Add

this allows you to type characters 汉字

the following steps will not work for 16.04 because they depend on ibus-m17n being installed (i'll update another time when i get them installed myself. here's a decent starting point

d - Select Chinese (SunPinyin), click Add

this also allows you to type chinese characters 汉字 (optional alternative)

e - select Chinese (hanyu pinyin (m17n)), click Add

this allows you to type hànyǔ pīnyīn (english characters with tone markers)

Logout Login<

  1. Test It Out


If when using Chinese(Pinyin) you have the bug where typing hanyu suggests ha nü sh and other similar, syllabic separation problems, first try this..

Open the terminal, Enter ibus restart

if that doesn't work here are a few other suggestions at Pinyin Joe

Random Tips

  • Press super key + space to toggle between language inputs.
  • super key is the windows key
  • Each language input has its own settings to customize usability.
  • Ex. On the language bar select Pinyin, click preferences.
  • This is the best and most complete answer, the only one that actually worked for me. Jan 13, 2018 at 16:02
  • @AlfredBaudisch Which version of Ubuntu did you enable it for? Jan 13, 2018 at 17:07
  • 1
    ubuntu 16.04.2 LTS Jan 13, 2018 at 23:27
  • For anybody reading the comments, Alfred's comment was posted before I made an update to the answer to include 16.04. The first step should get things working well enough for most users but for those wanting to use Hanyu Pinyin (tone marked English characters / hànyǔ pīnyīn) and other alternative Chinese character programs you will need to look elsewhere for answers until I install them myself and update this answer. Aug 10, 2018 at 3:18
  • Worked for me on Ubuntu 20.04 Dec 27, 2021 at 6:28

Here I provide a quick way to install Quick Input Method (速成輸入法) in your Ubuntu.

  1. Execute the following command to install the required packages.

    sudo apt-get install fcitx fcitx-imlist fcitx-table-quick-classic
  2. Restart your Ubuntu after the command execution.

  3. Launch Language Support. Set Keyboard input system to fcitx. enter image description here

  4. Launch Region & Language. Add Input Sources: Chinese (QuickClassic). enter image description here

  5. Now you can see the language menu icon. You can use Shift to switch between the input methods.

    enter image description here


This method is through command line. It relies on installing ibus-libpinyin (which is known as Ibus Intelligent Pinyin) and adding it as input source to gsettings schema. This has been tested multiple times on Ubuntu 14.04 LTS as well as 15.04

First install ibus-libpinyin

sudo apt-get install ibus-libpinyin

Then, run the following command:

gsettings set org.gnome.desktop.input-sources sources "$(gsettings get org.gnome.desktop.input-sources sources | sed "s/]/, ('ibus', 'libpinyin')]/")" 

The command above takes output of gsettings get org.gnome.desktop.input-sources sources, gives it to sed, which removes the last square bracket and appends , ('ibus', 'libpinyin')] to its output. That particular schema has entries in format [(INPUTMETHOD1, LANGUAGE1), (INPUTMETHOD1,LANGUAGE2)], so this is the reason why sed has to be used to insert text in that fassion. Finally we use output of that as input for gsettings set command, through parameter substitution with $( . . . )

Alternatively the two lines can be combined into a simple script:

sudo apt-get install ibus-libpinyin
gsettings set $SCHEMA $KEY "$(gsettings get $SCHEMA $KEY | sed "s/]/, ('ibus', 'libpinyin')]/")"

Hope that helps other users! Chinese language by itself is great for web-surfing Chinese internet, but one of the most desired app for Chinese users of Linux is QQ, which of course isn't available, however check out my other answer on how to install Android version of QQ in Ubuntu.

  • Well QQ has a web edition so android edition is not really necessary.
    – xji
    Sep 11, 2015 at 10:06
  • @XiangJi at least for me, web qq lacks file transfer and video/voice calling features. Besides, it's laggy and doesn't keep history of my conversations. Hence, I prefer android version. A bit verbose, but works for me Sep 11, 2015 at 19:59
  • This is the only answer that worked, under 2016.04 with gnome desktop. Sep 13, 2016 at 8:16
  • Still worked on Ubuntu 21.04
    – MikZuit
    Jul 1, 2021 at 21:15
  1. click dash home, search for "language support", check if " chinese" exist ? If not step 2. If have, transfer to step 3.

  2. click "install/remove language" and add Chinese

  3. click dash home, search for "keyboard input method"

  4. under "input method",add Chinese input method


I follow this one (link on my Ubuntu 18.04, which works for me.


I am following this for my Ubuntu 20.02 and looks like it helps me:


Hope this helps others.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .