I recently upgraded from 12.04 to 14.04, 64-bit. I found that after the upgrade, SCIM was no longer reading the KMFL folder, and associated KMN files, with the result that I am no longer able to type in the Salish languages I work on. SCIM itself appears to be working, however in the SCIM-setup menu, there is no listing for KMFL, as there used to be.

I have double-checked the keyboard input settings, making sure they are set to SCIM. I have also tried IBUS, downloaded ibus-kmfl from the SIL repositories, however IBUS is not reading the KMFL folder either.

These are the SCIM files I currently have installed: scim scim-m17n libscim8c2a scim-im-agent scim-modules-socket scim-gtk-immodule scim-kmfl-imengine

Can any one help with this?

  • Maybe I'm stupid, but.. Can you please explain what you mean by "reading the KMFL folder". Mar 6, 2015 at 22:20
  • Hi Gunnar, sorry for not being clear.... To use KMFL with SCIM, a folder named KMFL needs to be listed in the Home directory. The KMFL folder includes the individual KMN keyboard files. So I just meant that SCIM "Looks for" the KMN files in that location. thanks.
    – John Lyon
    Mar 6, 2015 at 22:53
  • Ok, thanks for the clarification. Guess this is a little above my head, though. Mar 7, 2015 at 10:28
  • UPDATE: IBUS and KMFL are working together now, but now the issue is that I can only switch keyboards using the terminal command: "ibus engine X.kmn". (And then the command "ibus exit" to switch back to English) The IBUS icon does not appear in the system tray, and the hotkeys which I use to switch keyboards do not work.
    – John Lyon
    Mar 10, 2015 at 17:16
  • 1
    Maybe you already know, but: When using IBus in 14.04, you should add the engines you want to use in System Settings -> Text Entry, and not use ibus-setup directly. Mar 10, 2015 at 17:25

2 Answers 2


It's a long shot, but do you have the icon files for the keyboard maps in place? When I speedily upgraded from Precise to Xenial via Trusty this weekend, I discovered that my KMfL keyboards were not working. Only by invoking ibus-setup did I discover that their icons were now being looked for in ~/.kmfl/icon, instead of ~/.kmfl/icons where they had always been found before. I fixed that with a soft link, in case the search location is corrected. The icons for keyboards /usr/share/kmfl are still being found in /usr/share/kmfl/icons.

On Xenial, I've found it convenient to start the ibus daemon by adding the line

ibus-daemon -d

at the end of my ~.profile script. I don't yet know whether this is needed for Trusty.

On Trusty, icons are still being found in ~/.kmfl/icons, but I'm having other problems there, so I don't have a solution that works on Trusty. GTK3 applications are finding the keyboards, but the IME promptly dies!


I installed ibus-kmfl in accordance with this guide. By putting the .kmn file in /usr/share/kmfl instead of ~/.kfml, I made the KMFL entry available in the list of input sources in Text Entry.

Input source indicator

  • Thanks again. Yes, my .kmn files are already in /usr/share/kmfl, and still the keyboards do not show up in the "Input Sources" List. Neither is there an "Other" listing, which the wikipedia link suggests might be the case. A related issue is that the ibus keyboard icon does not show in the system tray... and the hotkeys do not work. The only way to use the .kmn keyboard is to directly invoke it in the terminal.
    – John Lyon
    Apr 23, 2015 at 22:10
  • @JohnLyon: Well, in that case you have probably messed it up somehow, maybe when you played with ibus-setup, which you are expected to not touch in Ubuntu 14.04 (normally). Please note that no IBus icon is supposed to show up in Ubuntu. Instead the IBus input sources are shown, together with regular keyboard layouts, in the input source menu. I edited the answer, and added a screenshot of my own input source menu. Apr 24, 2015 at 0:19
  • @JohnLyon: The KMFL entries need to be added from the "Choose an input source" window, which you reach by selecting System Settings -> Text Entry and clicking the + (plus) button. (Saying that to prevent a possible trivial misunderstanding.) Apr 24, 2015 at 0:28
  • Thanks, no I didn't mess anything up in ibus-setup. The kmn keyboards still worked when they are invoked in the terminal, but they have never shown up in the list which you show there (thanks for the screenshot), since a fresh install of 14.04, nor in the System Settings -> Text Entry after clicking the + (plus) button. I actually just uninstalled ibus-kmfl from ubuntu software center in order to reinstalled it in the hopes that perhaps there was an update, but it is now no longer part of the repositories! Could you send me a list of other ibus related files you have installed?
    – John Lyon
    Apr 24, 2015 at 1:13
  • @JohnLyon: I installed ibus-kmfl from Ubuntu Software Center, but since it's not in the Ubuntu archive, I had to add the SIL repository first. Apr 24, 2015 at 1:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .