1

Bluefish worked for a while, but now I get:

(bluefish:11390): WARNING **: Couldn't register with accessibility bus: 
  Did not receive a reply. Possible causes include: 
  the remote application did not send a reply, 
  the message bus security policy blocked the reply, 
  the reply timeout expired, or the network connection was broken.
(bluefish:11390): GLib-ERROR **: /build/buildd/glib2.0-2.40.2/./glib/gmem.c:103:
  failed to allocate 18446744073682316418 bytes Trace/breakpoint trap

How should I proceed?

1
  • @CarlH: Please review my edits. Try not only to improve the grammar, spelling and formatting, but also the readability. Andy: Welcome to Ask Ubuntu! ;-) Could you please give us a bit more information like: what version of Ubuntu and Bluefish you're running? Please edit your question and add this information...
    – Fabby
    Mar 6, 2015 at 20:49

2 Answers 2

2

It's a bug of Bluefish. They insist that it was fixed in the latest version. First, make sure you have the latest stable version of Bluefish installed. Doesn't need to be the bleeding-edge final version, just suitable for your distro.

In my case it didn't worked anyway and I had this issue a couple of times. Basically, if you remove ~/.bluefish/session-2.0, it should work again.

1

As the last contributor said, it involves the ~/.bluefish/session-2.0 file in your home folder. to see this file, enable "show hidden files" by right clicking inside the folder and selecting "show hidden files". Once there, open this .bluefish folder, right click on the session-2.0 file and select properties, select the permissions tab, tick the execute box and then the set sticky bit box, close, close the editor and all should work fine. Can't explain why, but when the program creates or writes to the file, it is unsetting the execute permissions, setting the sticky bit seems to keep them set, and the program works again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .