8

Commands I've tried:

  • sudo updatedb
  • sudo fc-cache -fv
  • sudo reboot

Dispite this I was unable to make Monofur font to display as available for the Gnome Terminal in a machine with Ubuntu 14.10 recently installed. It's available in all other apps.

I have other machine with 14.04 where this went fine.

I'm not sure whether this is related with a problem when I installed the font for the first time and the font manager got stuck when installing that I had to reboot. Afterwards I've removed the font from the system and reinstalled it without problems.

It's in ~/.local/share/fonts.

fc-list lists this font. File permissions are OK.

UPDATE

Upgraded to last Ubuntu, issue vanished.

  • Installing this font and selecting it as default in gnome-terminal worked for me straightaway, even without any of the commands you mention. It's in my .local/share/fonts folder as well. – Jos Mar 6 '15 at 14:29
  • @Jos Maybe something went wrong when I've installed it for the first time and had to force reboot. But I've tried to remove it from any possible place it could be before reinstalling, still nothing. I can't select it since it doesn't display as an option. – pepper_chico Mar 6 '15 at 14:37
  • Can you use Monofur in other applications, e. g. LibreOffice or GEdit? – David Foerster Mar 9 '15 at 0:10
  • @DavidFoerster yes. – pepper_chico Mar 9 '15 at 0:11
  • 1
    @Fabby yes, and I think it has no effect about it being at last displayed as an option. Gnome Terminal just don't list it for some unknown reason. – pepper_chico Mar 15 '15 at 1:09
4

Whatever I did I couldn't get my fonts to show up. I got at a point where I tried switching random options, and when I switched "Allow bold text" off and back on all the fonts showed up. Don't ask me why but it worked for me.

  • 1
    Thanks! This was what worked for me finally. Weird, though! – ankush981 Dec 12 '15 at 13:55
  • Sadly, this option is missing in Ubuntu 18.04. I toggled it using dconf-editor per this answer, but it didn't seem to resolve the issue. – Alexander Nied Nov 4 '18 at 4:30
3

Having installed the font, it didn't show right away for me either. Here's the steps I took to make it show up:

1) Move the font to /usr/share/fonts/truetype` directory:

Create a directory /usr/share/fonts/truetype/Monofur/ and move the font files (in my case, I only moved Monofur for Powerline.ttf) either with file manager or with mv command. Note, you will need sudo priviliges for all that

2) Delete everything in ~/.gconf/apps/gnome-terminal/

The profile preferences are all stored in ~/.gconf/apps/gnome-terminal/ directory. I basically did sudo rm -r ~/.gconf/apps/gnome-terminal/

3) Close and reopen gnome-terminal

Self- explanatory.

Suggestions:

For good measure, try doing updatedb after deleting everything or after reopening gnome-terminal; try rebooting if it still doesn't work

  • Sorry but this didn't work, even after reboot. – pepper_chico Mar 10 '15 at 17:46
  • What's the permissions on the files by the way? – Sergiy Kolodyazhnyy Mar 10 '15 at 20:02
  • All -rw-r--r-- (same as for other fonts in other directories). I need all the 3 fonts by the way, so I've copied all of them. – pepper_chico Mar 10 '15 at 20:10
  • Weird. I've no other ideas so far. – Sergiy Kolodyazhnyy Mar 10 '15 at 20:32
  • Had a thought : how about attempting a reinstall of gnome-terminal ? – Sergiy Kolodyazhnyy Mar 10 '15 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.