I’m running Ubuntu 14.04. When I run:

sudo add-apt-repository ppa:ubuntu-wine/ppa

I get the following error:

sudo: add-apt-repository: command not found

I tried to run

sudo apt-get install software-properties-common

but it shows:

software-properties-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
  • 1
    This is an old post, and maybe the OP no longer cares! However did you try sudo apt install software-properties-common --reinstall? May 17, 2019 at 10:05

3 Answers 3


For Ubuntu 14.04 or later you need to install the software-properties-common package:

sudo apt install software-properties-common

I found the solution in this blog: Ubuntu Server 14.4 (Trusty Tahr) – add-apt-repository: command not found

  • That worked for me as well on Debian but only after running "apt-get update" could I install any new ppas.
    – Hagbard
    Jan 13, 2021 at 15:29

If you are using an older release of Ubuntu, i.e. before 12.10, it is necessary to install the package python-software-properties.

sudo apt install python-software-properties
  • I had this issue on Ubuntu 16.04 LTS. This fixed it, but I had to also reboot the server after installing. Aug 15, 2019 at 10:45
  • This solved it for me on Ubuntu 14.04 LTS. software-properties-common was already installed.
    – kap
    Oct 11, 2019 at 11:55
  • This solved it for me on Ubuntu 12.04.5 LTS, as software-properties-common was already installed. Aug 28, 2020 at 0:18

Run sudo apt-get update

Then sudo apt install software-properties-common -y

Now, you can use sudo add-apt-repository

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.