1

The following isn't very important but I wanted to ask out of interest. The window design layout inside of WPS Office looks a bit old-fashioned. I haven't checked all other programmes but to me it seems that all other programmes have the normal Unity style.

Any idea what that could be or how to investigate this issue further. I tend to believe that before my Ubuntu crashed and I reinstalled it, the windows were in normal Unity layout. It's not only the buttons but also the mouse cursor is black instead of white and the loading-up mouse cursor is the super old black watch not the white spinning Unity circle. Here is a screenshot from inside WPS Office

Any ideas, please let me know.

Cheers.

  • It looks to me than that program is using QT and the qt theme settings for it are not using the "gtk" theme. You may need to install qt4-qtconfig in ubuntu and open it. – xangua Mar 6 '15 at 1:44
  • Hi xangua! I followed your suggestion and installed qt4-qtconfig. Any chance to explain what you meant by 'open it', please? Simply entering 'qt4-qtconfig' in the terminal yielded command not found – johann_ka Mar 6 '15 at 9:02
  • It should appear in the unity dash. – xangua Mar 6 '15 at 9:50
  • Yup, qt4-qtconfig comes up in the Unity dash. Any suggestions on which settings I should try before I start messing around with the system? – johann_ka Mar 6 '15 at 18:14
1

Try to install this dependencies:

sudo apt-get install libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

Daniel Renninghoff (renninghoff) wrote on 2012-05-09: Better description of the bug: QGtkStyle tries to find the current gtk theme but is not able to do so and falls back to clearlooks. This applies to all 32bit Qt applications on a 64bit system. I believe QGtkStyle uses libgnomeui to find the correct GTK Style but is not able to do that because the lib is only available in 64bit form. Trying to install the i386 version will replace the 64bit version. The other problem is that QGtkStyle also expects the GTK Theme Engine to be in 32bit, so you have to install gtk2-engines-murrine:i386 for the default light-themes. https://bugs.launchpad.net/ubuntu/+source/skype/+bug/863218

| improve this answer | |
  • @ Mikel Vysotsky, you are a genius, this solved the issue with WPS Office on my Ubuntu 14.04! Cheers once more! – johann_ka Mar 31 '15 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.